summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-18 18:38:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-01-18 18:38:15 +0000
commit8059000bcbb9024cdf1726bc05cfaa757b86bab2 (patch)
treeb72115f20ca3d1be5cfde0c4559fb3c2cee6303d /dev-python/html5lib
parentDelete older ebuild. (diff)
downloadgentoo-2-8059000bcbb9024cdf1726bc05cfaa757b86bab2.tar.gz
gentoo-2-8059000bcbb9024cdf1726bc05cfaa757b86bab2.tar.bz2
gentoo-2-8059000bcbb9024cdf1726bc05cfaa757b86bab2.zip
Version bump.
(Portage version: 15200-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/html5lib')
-rw-r--r--dev-python/html5lib/ChangeLog10
-rw-r--r--dev-python/html5lib/html5lib-0.90.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-python/html5lib/ChangeLog b/dev-python/html5lib/ChangeLog
index a764d9d644d1..ba5dc421cc99 100644
--- a/dev-python/html5lib/ChangeLog
+++ b/dev-python/html5lib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/html5lib
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.3 2009/12/22 23:58:12 arfrever Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/ChangeLog,v 1.4 2010/01/18 18:38:15 arfrever Exp $
+
+*html5lib-0.90 (18 Jan 2010)
+
+ 18 Jan 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +html5lib-0.90.ebuild:
+ Version bump.
*html5lib-0.11.1-r1 (23 Dec 2009)
diff --git a/dev-python/html5lib/html5lib-0.90.ebuild b/dev-python/html5lib/html5lib-0.90.ebuild
new file mode 100644
index 000000000000..f470d6320d29
--- /dev/null
+++ b/dev-python/html5lib/html5lib-0.90.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/html5lib/html5lib-0.90.ebuild,v 1.1 2010/01/18 18:38:15 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="HTML parser based on the HTML5 specification"
+HOMEPAGE="http://code.google.com/p/html5lib/ http://pypi.python.org/pypi/html5lib"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-lang/python[xml]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ >=dev-python/setuptools-0.6_rc5"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_install() {
+ distutils_src_install
+
+ if use examples ; then
+ find examples -name "*.pyc" | xargs rm -fr
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples || die "Installation of examples failed"
+ fi
+}