summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-09-21 04:25:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-09-21 04:25:26 +0000
commit44d182e71a31e6bb78e1610624ca5b29601ff2eb (patch)
tree106af930c96f48d7dea2ef74f2768e4702c964fc /dev-python/h5py
parentAdded dev-python/optik for removal in 30 days (diff)
downloadgentoo-2-44d182e71a31e6bb78e1610624ca5b29601ff2eb.tar.gz
gentoo-2-44d182e71a31e6bb78e1610624ca5b29601ff2eb.tar.bz2
gentoo-2-44d182e71a31e6bb78e1610624ca5b29601ff2eb.zip
Initial import to the main tree
(Portage version: 2.2_rc41/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/h5py')
-rw-r--r--dev-python/h5py/ChangeLog39
-rw-r--r--dev-python/h5py/h5py-1.2.1.ebuild22
-rw-r--r--dev-python/h5py/metadata.xml14
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/h5py/ChangeLog b/dev-python/h5py/ChangeLog
new file mode 100644
index 000000000000..5326071ca2bd
--- /dev/null
+++ b/dev-python/h5py/ChangeLog
@@ -0,0 +1,39 @@
+# ChangeLog for dev-python/h5py
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/ChangeLog,v 1.1 2009/09/21 04:25:26 bicatali Exp $
+
+ 21 Sep 2009; Sébastien Fabbro <bicatali@gentoo.org> +h5py-1.2.1.ebuild,
+ +metadata.xml:
+ Initial import to the main tree
+
+*h5py-1.2.1 (20 Sep 2009)
+
+ 20 Sep 2009; Tim Cera <timcera@earthlink.net> +h5py-1.2.1.ebuild:
+ Version bump.
+
+*h5py-1.2.0 (10 Jul 2009)
+
+ 10 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> -h5py-1.0.0.ebuild,
+ +h5py-1.2.0.ebuild:
+ Version bump. Changed dependency and added test
+
+ 19 Jun 2009; Justin Bronder <jsbronder@gentoo.org> h5py-1.1.0.ebuild:
+ Fix SRC_URI and digest.
+
+*h5py-1.1.0 (10 Jun 2009)
+
+ 10 Jun 2009; Tim Cera <timcera@earthlink.net> -h5py-0.3.1.ebuild,
+ +h5py-1.1.0.ebuild:
+ Version bump.
+
+ 19 Jan 2009; Tim Cera <timcera@earthlink.net> +h5py-1.0.0.ebuild:
+ Bumped version to 1.0.0.
+
+ 05 Nov 2008; Tim Cera <timcera@earthlink.net> +h5py-0.3.1.ebuild,
+ +metadata.xml:
+ Added license info.
+
+ 04 Nov 2008; Tim Cera <timcera@earthlink.net> +h5py-0.3.1.ebuild,
+ +metadata.xml:
+ Initial ebuild.
+
diff --git a/dev-python/h5py/h5py-1.2.1.ebuild b/dev-python/h5py/h5py-1.2.1.ebuild
new file mode 100644
index 000000000000..853a92a30f91
--- /dev/null
+++ b/dev-python/h5py/h5py-1.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-1.2.1.ebuild,v 1.1 2009/09/21 04:25:26 bicatali Exp $
+
+inherit distutils
+
+DESCRIPTION="A simple Python interface to HDF5 files."
+HOMEPAGE="http://h5py.alfven.org/"
+SRC_URI="http://h5py.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sci-libs/hdf5-1.6.7
+ dev-python/numpy"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ "${python}" setup.py test || die "test failed"
+}
diff --git a/dev-python/h5py/metadata.xml b/dev-python/h5py/metadata.xml
new file mode 100644
index 000000000000..96252fd400ed
--- /dev/null
+++ b/dev-python/h5py/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription lang="en">
+ HDF5 for Python (h5py) is a general-purpose simple Python interface to the
+ Hierarchical Data Format library, version 5. Existing Python and
+ Numpy concepts are used for the interface. Almost all HDF5 features
+ are available from Python, including things like compound datatypes
+ (as used with Numpy recarray types), HDF5 attributes, hyperslab and
+ point-based I/O, and more recent features in HDF 1.8 like resizable
+ datasets and recursive iteration over entire files.
+</longdescription>
+</pkgmetadata>