summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2014-07-23 09:31:18 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2014-07-23 09:31:18 +0000
commitfdb7d2b6212f023c70297d3658f99016f8f95ca7 (patch)
tree83d8db5454b55252b5153a1237baa8919d5660cd /dev-python/h5py/h5py-2.3.1.ebuild
parentamd64 stable, bug #512012 (diff)
downloadgentoo-2-fdb7d2b6212f023c70297d3658f99016f8f95ca7.tar.gz
gentoo-2-fdb7d2b6212f023c70297d3658f99016f8f95ca7.tar.bz2
gentoo-2-fdb7d2b6212f023c70297d3658f99016f8f95ca7.zip
Make sure that --mpi is passed to setup.py during each stage
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'dev-python/h5py/h5py-2.3.1.ebuild')
-rw-r--r--dev-python/h5py/h5py-2.3.1.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/dev-python/h5py/h5py-2.3.1.ebuild b/dev-python/h5py/h5py-2.3.1.ebuild
index 261ef0d45fba..4022cf3cb2c1 100644
--- a/dev-python/h5py/h5py-2.3.1.ebuild
+++ b/dev-python/h5py/h5py-2.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.3.1.ebuild,v 1.2 2014/07/23 09:01:56 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/h5py/h5py-2.3.1.ebuild,v 1.3 2014/07/23 09:31:18 xarthisius Exp $
EAPI=5
@@ -26,27 +26,27 @@ DEPEND="${RDEPEND}
mpi? ( dev-python/mpi4py[${PYTHON_USEDEP}] )"
DISTUTILS_NO_PARALLEL_BUILD=1
+pkg_setup() {
+ if use mpi ; then
+ export CC=mpicc
+ fi
+}
+
python_prepare_all() {
append-cflags -fno-strict-aliasing
distutils-r1_python_prepare_all
}
python_compile() {
- if use mpi;then
- export CC=mpicc
- distutils-r1_python_compile --mpi=yes
- else
- distutils-r1_python_compile
- fi
+ distutils-r1_python_compile --mpi=$(usex mpi yes no)
}
python_test() {
- if use mpi ; then
- export CC=mpicc
- esetup.py test --mpi
- else
- esetup.py test
- fi
+ esetup.py test --mpi=$(usex mpi yes no)
+}
+
+python_install() {
+ distutils-r1_python_install --mpi=$(usex mpi yes no)
}
python_install_all() {