summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-26 17:26:48 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-26 17:26:48 +0000
commit085ebf49d910eeceff2769a000e6acf68b827623 (patch)
treebfa70af950bd7ade16d97f731751832570a32584 /dev-python/gnome-vfs-python
parentVersion bump (diff)
downloadgentoo-2-085ebf49d910eeceff2769a000e6acf68b827623.tar.gz
gentoo-2-085ebf49d910eeceff2769a000e6acf68b827623.tar.bz2
gentoo-2-085ebf49d910eeceff2769a000e6acf68b827623.zip
Convert to gnome-python-common-r1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/gnome-vfs-python')
-rw-r--r--dev-python/gnome-vfs-python/ChangeLog11
-rw-r--r--dev-python/gnome-vfs-python/gnome-vfs-python-2.28.1-r1.ebuild25
2 files changed, 33 insertions, 3 deletions
diff --git a/dev-python/gnome-vfs-python/ChangeLog b/dev-python/gnome-vfs-python/ChangeLog
index 2f190e2204b7..cdee48833938 100644
--- a/dev-python/gnome-vfs-python/ChangeLog
+++ b/dev-python/gnome-vfs-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-vfs-python
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-vfs-python/ChangeLog,v 1.38 2012/02/24 08:43:24 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-vfs-python/ChangeLog,v 1.39 2014/05/26 17:26:48 mgorny Exp $
+
+*gnome-vfs-python-2.28.1-r1 (26 May 2014)
+
+ 26 May 2014; Michał Górny <mgorny@gentoo.org>
+ +gnome-vfs-python-2.28.1-r1.ebuild:
+ Convert to gnome-python-common-r1.
24 Feb 2012; Patrick Lauer <patrick@gentoo.org>
gnome-vfs-python-2.28.1.ebuild:
@@ -163,4 +169,3 @@
+gnome-vfs-python-2.22.1.ebuild:
Initial import of gnome-python split ebuilds. This package installs
bindings for the GnomeVFS library.
-
diff --git a/dev-python/gnome-vfs-python/gnome-vfs-python-2.28.1-r1.ebuild b/dev-python/gnome-vfs-python/gnome-vfs-python-2.28.1-r1.ebuild
new file mode 100644
index 000000000000..338f9804573c
--- /dev/null
+++ b/dev-python/gnome-vfs-python/gnome-vfs-python-2.28.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-vfs-python/gnome-vfs-python-2.28.1-r1.ebuild,v 1.1 2014/05/26 17:26:48 mgorny Exp $
+
+EAPI="5"
+
+GNOME_ORG_MODULE="gnome-python"
+G_PY_BINDINGS=( gnomevfs gnomevfsbonobo pyvfsmodule )
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome-python-common-r1
+
+DESCRIPTION="Python bindings for the GnomeVFS library"
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc examples"
+
+RDEPEND="dev-python/pygobject:2[${PYTHON_USEDEP}]
+ >=gnome-base/gnome-vfs-2.24.0
+ >=gnome-base/libbonobo-2.8
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}"
+
+EXAMPLES=( examples/vfs/. )