summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-26 16:18:05 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-26 16:18:05 +0000
commitebafeb6686552277d8165a7c0b6dd3101988cfe4 (patch)
tree2103c1f31e9a3ba07b886287814421eb4323394b /dev-python/gnome-python-base
parentMove python_fix_shebang into python-utils-r1, therefore making it a part of p... (diff)
downloadgentoo-2-ebafeb6686552277d8165a7c0b6dd3101988cfe4.tar.gz
gentoo-2-ebafeb6686552277d8165a7c0b6dd3101988cfe4.tar.bz2
gentoo-2-ebafeb6686552277d8165a7c0b6dd3101988cfe4.zip
Convert to python-any-r1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/gnome-python-base')
-rw-r--r--dev-python/gnome-python-base/ChangeLog8
-rw-r--r--dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/gnome-python-base/ChangeLog b/dev-python/gnome-python-base/ChangeLog
index 16ce7d41b16b..65aa586de872 100644
--- a/dev-python/gnome-python-base/ChangeLog
+++ b/dev-python/gnome-python-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/gnome-python-base
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.42 2014/01/16 15:56:36 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/ChangeLog,v 1.43 2014/05/26 16:18:05 mgorny Exp $
+
+*gnome-python-base-2.28.1-r1 (26 May 2014)
+
+ 26 May 2014; Michał Górny <mgorny@gentoo.org>
+ +gnome-python-base-2.28.1-r1.ebuild:
+ Convert to python-any-r1.
16 Jan 2014; Anthony G. Basile <blueness@gentoo.org>
gnome-python-base-2.28.1.ebuild:
diff --git a/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
new file mode 100644
index 000000000000..3180efb98c81
--- /dev/null
+++ b/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gnome-python-base/gnome-python-base-2.28.1-r1.ebuild,v 1.1 2014/05/26 16:18:05 mgorny Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit versionator eutils gnome2 python-any-r1
+
+# This ebuild does nothing -- we just want to get the pkgconfig file installed
+
+MY_PN="gnome-python"
+DESCRIPTION="Provides the base files for the gnome-python bindings"
+HOMEPAGE="http://pygtk.org/"
+PVP="$(get_version_component_range 1-2)"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP}/${MY_PN}-${PV}.tar.bz2"
+
+IUSE=""
+LICENSE="LGPL-2.1"
+SLOT="2"
+RESTRICT="${RESTRICT} test"
+
+# From the gnome-python eclass
+RDEPEND=">=x11-libs/gtk+-2.6:2
+ >=dev-libs/glib-2.6:2
+ $(python_gen_any_dep '
+ >=dev-python/pygtk-2.14.0:2[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.17:2[${PYTHON_USEDEP}]
+ ')
+ !<dev-python/gnome-python-2.22.1"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-allbindings"
+ python-any-r1_pkg_setup
+}