summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-11-26 06:08:05 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-11-26 06:08:05 +0000
commitbd242ec2d99491719cb61a0ebb12002d93b5fdc1 (patch)
treed06a8055862453e14a7fafa972729938f2206472 /dev-python/geopy/geopy-0.96.2.ebuild
parentBump (diff)
downloadgentoo-2-bd242ec2d99491719cb61a0ebb12002d93b5fdc1.tar.gz
gentoo-2-bd242ec2d99491719cb61a0ebb12002d93b5fdc1.tar.bz2
gentoo-2-bd242ec2d99491719cb61a0ebb12002d93b5fdc1.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/geopy/geopy-0.96.2.ebuild')
-rw-r--r--dev-python/geopy/geopy-0.96.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/geopy/geopy-0.96.2.ebuild b/dev-python/geopy/geopy-0.96.2.ebuild
new file mode 100644
index 000000000000..58280ddca25d
--- /dev/null
+++ b/dev-python/geopy/geopy-0.96.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/geopy/geopy-0.96.2.ebuild,v 1.1 2013/11/26 06:08:05 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Geocoding Toolbox for Python"
+HOMEPAGE="http://www.geopy.org/ http://pypi.python.org/pypi/geopy http://code.google.com/p/geopy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+IUSE="test"
+
+RDEPEND="<=dev-python/beautifulsoup-4.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}