summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-06 17:15:04 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-06 17:15:04 +0000
commitf07bc27a4079752519f600ac01e1bf566812a91d (patch)
tree57be97afeb4d097b32766c76d6f5a7f3ad72b2ab /dev-python/gdmodule
parentVersion bump to work with pcsc-lite 1.6.5; tweak dependencies for previous ve... (diff)
downloadgentoo-2-f07bc27a4079752519f600ac01e1bf566812a91d.tar.gz
gentoo-2-f07bc27a4079752519f600ac01e1bf566812a91d.tar.bz2
gentoo-2-f07bc27a4079752519f600ac01e1bf566812a91d.zip
Added DISTUTILS_SETUP_FILES=(Setup.py) to global scope, suggested by Afrever on irc
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/gdmodule')
-rw-r--r--dev-python/gdmodule/ChangeLog7
-rw-r--r--dev-python/gdmodule/gdmodule-0.56-r2.ebuild8
-rw-r--r--dev-python/gdmodule/gdmodule-0.56.ebuild11
3 files changed, 12 insertions, 14 deletions
diff --git a/dev-python/gdmodule/ChangeLog b/dev-python/gdmodule/ChangeLog
index 6a631b4e7a4b..c9e6dbbb1674 100644
--- a/dev-python/gdmodule/ChangeLog
+++ b/dev-python/gdmodule/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gdmodule
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdmodule/ChangeLog,v 1.4 2010/12/06 15:53:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdmodule/ChangeLog,v 1.5 2010/12/06 17:15:04 jlec Exp $
+
+ 06 Dec 2010; Justin Lecher <jlec@gentoo.org> gdmodule-0.56.ebuild,
+ gdmodule-0.56-r2.ebuild:
+ Added DISTUTILS_SETUP_FILES=(Setup.py) to global scope, suggested by Afrever
+ on irc
*gdmodule-0.56-r2 (06 Dec 2010)
diff --git a/dev-python/gdmodule/gdmodule-0.56-r2.ebuild b/dev-python/gdmodule/gdmodule-0.56-r2.ebuild
index fba512d4e46a..a5781718c962 100644
--- a/dev-python/gdmodule/gdmodule-0.56-r2.ebuild
+++ b/dev-python/gdmodule/gdmodule-0.56-r2.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdmodule/gdmodule-0.56-r2.ebuild,v 1.1 2010/12/06 15:53:25 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdmodule/gdmodule-0.56-r2.ebuild,v 1.2 2010/12/06 17:15:04 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SETUP_FILES=("Setup.py")
inherit distutils eutils flag-o-matic
@@ -27,8 +29,6 @@ RDEPEND="
xpm? ( x11-libs/libXpm )"
DEPEND="${RDEPEND}"
-RESTRICT_PYTHON_ABIS="3.*"
-
src_prepare() {
epatch "${FILESDIR}"/${P}-fix-libs.patch
@@ -40,7 +40,5 @@ src_prepare() {
use truetype && append-cppflags -DHAVE_LIBFREETYPE
use xpm && append-cppflags -DHAVE_LIBXPM
- mv Setup.py setup.py
-
distutils_src_prepare
}
diff --git a/dev-python/gdmodule/gdmodule-0.56.ebuild b/dev-python/gdmodule/gdmodule-0.56.ebuild
index 0e34bad11a73..c14a3425eb39 100644
--- a/dev-python/gdmodule/gdmodule-0.56.ebuild
+++ b/dev-python/gdmodule/gdmodule-0.56.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gdmodule/gdmodule-0.56.ebuild,v 1.2 2010/11/10 17:45:31 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gdmodule/gdmodule-0.56.ebuild,v 1.3 2010/12/06 17:15:04 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SETUP_FILES=("Setup.py")
inherit distutils
@@ -20,10 +22,3 @@ IUSE=""
RDEPEND="media-libs/gd"
DEPEND="${RDEPEND}"
-
-RESTRICT_PYTHON_ABIS="3.*"
-
-src_prepare() {
- mv Setup.py setup.py
- distutils_src_prepare
-}