summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2011-10-08 17:17:45 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2011-10-08 17:17:45 +0000
commit84a16234eda87d35e8cf50bde752d2fdec3c0e2e (patch)
tree3df6ab54688a79f724117e70b1f8e5b925c70dec /dev-python/flask
parentold (diff)
downloadgentoo-2-84a16234eda87d35e8cf50bde752d2fdec3c0e2e.tar.gz
gentoo-2-84a16234eda87d35e8cf50bde752d2fdec3c0e2e.tar.bz2
gentoo-2-84a16234eda87d35e8cf50bde752d2fdec3c0e2e.zip
Version bump.
(Portage version: 2.2.0_alpha59_p57/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/flask')
-rw-r--r--dev-python/flask/ChangeLog7
-rw-r--r--dev-python/flask/flask-0.8.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/flask/ChangeLog b/dev-python/flask/ChangeLog
index 00867a237c18..550af4653969 100644
--- a/dev-python/flask/ChangeLog
+++ b/dev-python/flask/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/flask
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.8 2011/07/06 18:58:42 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/ChangeLog,v 1.9 2011/10/08 17:17:45 rafaelmartins Exp $
+
+*flask-0.8 (08 Oct 2011)
+
+ 08 Oct 2011; Rafael G. Martins <rafaelmartins@gentoo.org> +flask-0.8.ebuild:
+ Version bump.
*flask-0.7.2 (06 Jul 2011)
diff --git a/dev-python/flask/flask-0.8.ebuild b/dev-python/flask/flask-0.8.ebuild
new file mode 100644
index 000000000000..9716e8fb62ce
--- /dev/null
+++ b/dev-python/flask/flask-0.8.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/flask/flask-0.8.ebuild,v 1.1 2011/10/08 17:17:45 rafaelmartins Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="Flask"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A microframework based on Werkzeug, Jinja2 and good intentions"
+HOMEPAGE="http://pypi.python.org/pypi/Flask"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="dev-python/blinker
+ >=dev-python/jinja-2.4
+ dev-python/setuptools
+ >=dev-python/werkzeug-0.6.1"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.6 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ PYTHONPATH=".." emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="." "$(PYTHON)" run-tests.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd docs/_build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _images _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}