summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-11-07 04:29:53 +0000
committerIan Delaney <idella4@gentoo.org>2014-11-07 04:29:53 +0000
commit00870af8264d4fe4d6b4bcce561181cfcf4070cc (patch)
treec14bb22c195a4b516e4381523395ed512523e517 /dev-python/fabric
parentRemove old (diff)
downloadgentoo-2-00870af8264d4fe4d6b4bcce561181cfcf4070cc.tar.gz
gentoo-2-00870af8264d4fe4d6b4bcce561181cfcf4070cc.tar.bz2
gentoo-2-00870af8264d4fe4d6b4bcce561181cfcf4070cc.zip
ditto to fabric-1.10.0.ebuild wrt Bug #528154
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/fabric')
-rw-r--r--dev-python/fabric/ChangeLog5
-rw-r--r--dev-python/fabric/fabric-1.10.0.ebuild16
2 files changed, 13 insertions, 8 deletions
diff --git a/dev-python/fabric/ChangeLog b/dev-python/fabric/ChangeLog
index 8b053a5eff23..7da2b19a0e13 100644
--- a/dev-python/fabric/ChangeLog
+++ b/dev-python/fabric/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/fabric
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/ChangeLog,v 1.51 2014/11/06 03:27:54 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/ChangeLog,v 1.52 2014/11/07 04:29:53 idella4 Exp $
+
+ 07 Nov 2014; Ian Delaney <idella4@gentoo.org> fabric-1.10.0.ebuild:
+ ditto to fabric-1.10.0.ebuild wrt Bug #528154
06 Nov 2014; Ian Delaney <idella4@gentoo.org> fabric-1.9.1.ebuild:
Set required bordering to dep paramiko, fixes Bug #528154
diff --git a/dev-python/fabric/fabric-1.10.0.ebuild b/dev-python/fabric/fabric-1.10.0.ebuild
index fe9d2748a543..d3a38ad9ba9b 100644
--- a/dev-python/fabric/fabric-1.10.0.ebuild
+++ b/dev-python/fabric/fabric-1.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.10.0.ebuild,v 1.2 2014/10/08 08:54:29 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fabric/fabric-1.10.0.ebuild,v 1.3 2014/11/07 04:29:53 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 ) # py2 only
@@ -19,16 +19,18 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
-# since 'paramiko>=1.10' is what we have in portage, paramiko can be set unversioned
-RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/paramiko-1.10[${PYTHON_USEDEP}]
+ <dev-python/paramiko-1.13[${PYTHON_USEDEP}]
+ "
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/python-docs-2.7.6-r1:2.7
- dev-python/alabaster[${PYTHON_USEDEP}] )
+ >=dev-python/python-docs-2.7.6-r1:2.7
+ dev-python/alabaster[${PYTHON_USEDEP}] )
test? ( dev-python/nose[${PYTHON_USEDEP}]
- <dev-python/fudge-1.0[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}] )"
+ <dev-python/fudge-1.0[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}] )"
S="${WORKDIR}/${MY_P}"