summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 15:08:13 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-30 15:08:13 +0000
commit0ad058b1694bd12138c711f834f38b19cc82370f (patch)
tree8b495082d2cb9a361ccfe0c7dadcad6e3cf037b6 /dev-python/etsdevtools
parentMove live ebuild to eapi4. (diff)
downloadgentoo-2-0ad058b1694bd12138c711f834f38b19cc82370f.tar.gz
gentoo-2-0ad058b1694bd12138c711f834f38b19cc82370f.tar.bz2
gentoo-2-0ad058b1694bd12138c711f834f38b19cc82370f.zip
Version bump.
(Portage version: 2.2.0_alpha19_p24/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/etsdevtools')
-rw-r--r--dev-python/etsdevtools/ChangeLog8
-rw-r--r--dev-python/etsdevtools/etsdevtools-3.1.1.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-python/etsdevtools/ChangeLog b/dev-python/etsdevtools/ChangeLog
index 5b4aaead0000..c2b21807ffb6 100644
--- a/dev-python/etsdevtools/ChangeLog
+++ b/dev-python/etsdevtools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/etsdevtools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/etsdevtools/ChangeLog,v 1.12 2011/01/27 10:00:52 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/etsdevtools/ChangeLog,v 1.13 2011/01/30 15:08:13 arfrever Exp $
+
+*etsdevtools-3.1.1 (30 Jan 2011)
+
+ 30 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +etsdevtools-3.1.1.ebuild:
+ Version bump.
27 Jan 2011; Markos Chandras <hwoarang@gentoo.org> etsdevtools-3.1.0.ebuild:
Stable on amd64 wrt bug #347107
diff --git a/dev-python/etsdevtools/etsdevtools-3.1.1.ebuild b/dev-python/etsdevtools/etsdevtools-3.1.1.ebuild
new file mode 100644
index 000000000000..babdf7d59bb8
--- /dev/null
+++ b/dev-python/etsdevtools/etsdevtools-3.1.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/etsdevtools/etsdevtools-3.1.1.ebuild,v 1.1 2011/01/30 15:08:13 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils
+
+MY_PN="ETSDevTools"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Enthought tools to support Python development"
+HOMEPAGE="http://code.enthought.com/projects/ets_dev_tools.php http://pypi.python.org/pypi/ETSDevTools"
+SRC_URI="http://www.enthought.com/repo/ETS/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples wxwidgets"
+
+RDEPEND="dev-python/docutils
+ dev-python/nose
+ dev-python/numpy
+ dev-python/setuptools
+ >=dev-python/traitsgui-3.6.0
+ wxwidgets? ( dev-python/wxpython:2.8 )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="enthought"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ find -name "*LICENSE.txt" -delete
+ distutils_src_install
+
+ if use doc; then
+ dodoc docs/*/*.pdf || die "Installation of PDF documentation failed"
+ pushd docs/build/html > /dev/null
+ insinto /usr/share/doc/${PF}/html
+ doins -r [a-z]* _static || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}