summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-04-05 14:19:00 +0000
committerIan Delaney <idella4@gentoo.org>2013-04-05 14:19:00 +0000
commit20cbc94160b2ab9e6913d9b3848216e38ce53ae0 (patch)
treede84c3514b823ec8f51515934ef618ef731eb521 /dev-python/encore
parentStable for amd64, wrt bug #464340 (diff)
downloadgentoo-2-20cbc94160b2ab9e6913d9b3848216e38ce53ae0.tar.gz
gentoo-2-20cbc94160b2ab9e6913d9b3848216e38ce53ae0.tar.bz2
gentoo-2-20cbc94160b2ab9e6913d9b3848216e38ce53ae0.zip
bump
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/encore')
-rw-r--r--dev-python/encore/ChangeLog9
-rw-r--r--dev-python/encore/encore-0.3.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/dev-python/encore/ChangeLog b/dev-python/encore/ChangeLog
index 790e5214b6b0..c778e4dc6edf 100644
--- a/dev-python/encore/ChangeLog
+++ b/dev-python/encore/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/encore
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/encore/ChangeLog,v 1.1 2012/12/06 18:24:08 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/encore/ChangeLog,v 1.2 2013/04/05 14:19:00 idella4 Exp $
+
+*encore-0.3 (05 Apr 2013)
+
+ 05 Apr 2013; Ian Delaney <idella4@gentoo.org> +encore-0.3.ebuild:
+ bump
*encore-0.2 (06 Dec 2012)
diff --git a/dev-python/encore/encore-0.3.ebuild b/dev-python/encore/encore-0.3.ebuild
new file mode 100644
index 000000000000..3fd635dd9367
--- /dev/null
+++ b/dev-python/encore/encore-0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/encore/encore-0.3.ebuild,v 1.1 2013/04/05 14:19:00 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Enthought Tool Suite: collection of core-level utility modules"
+HOMEPAGE="https://github.com/enthought/encore"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND=""
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/futures[${PYTHON_USEDEP}] )"
+
+DOCS="dataflow.txt"
+
+python_prepare_all() {
+ # use of port 8080 is highly prone to prior use on testing
+ sed -e 's:self.port = 8080:self.port = 8020:' \
+ -i encore/storage/tests/static_url_store_test.py || die
+}
+
+python_compile_all() {
+ use doc && PYTHONPATH="$(ls -1d ${S}/build*/lib | head -n1)" \
+ emake -C docs html
+}
+
+python_test() {
+ # as set for py2.6 in 0.2, likely due to tests coded to import only unittest
+ [[ "${EPYTHON:6:3}" = '2.6' ]] && return
+ nosetests || die
+}
+
+python_install_all() {
+ find -name "*LICENSE*.txt" -delete
+ use doc && dohtml -r docs/build/html/*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}