summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-04 11:41:05 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-04 11:41:05 +0000
commit64cc69cb209e90abe5a4d1f021737bb61f7f3229 (patch)
treea694164cf07521b7b538b905ecded6bac779e441 /dev-python/drpython
parentAdd ruby20 and ruby21 support. (diff)
downloadgentoo-2-64cc69cb209e90abe5a4d1f021737bb61f7f3229.tar.gz
gentoo-2-64cc69cb209e90abe5a4d1f021737bb61f7f3229.tar.bz2
gentoo-2-64cc69cb209e90abe5a4d1f021737bb61f7f3229.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/drpython')
-rw-r--r--dev-python/drpython/ChangeLog11
-rw-r--r--dev-python/drpython/drpython-3.11.4.ebuild47
-rw-r--r--dev-python/drpython/files/drpython-165-wxversion.patch4
3 files changed, 57 insertions, 5 deletions
diff --git a/dev-python/drpython/ChangeLog b/dev-python/drpython/ChangeLog
index 1d7140dbc7e1..bea8e2ef17af 100644
--- a/dev-python/drpython/ChangeLog
+++ b/dev-python/drpython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/drpython
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/ChangeLog,v 1.19 2012/02/24 08:16:19 patrick Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/ChangeLog,v 1.20 2014/05/04 11:41:05 idella4 Exp $
+
+*drpython-3.11.4 (04 May 2014)
+
+ 04 May 2014; Ian Delaney <idella4@gentoo.org> +drpython-3.11.4.ebuild,
+ files/drpython-165-wxversion.patch:
+ bump
24 Feb 2012; Patrick Lauer <patrick@gentoo.org> drpython-3.11.3.ebuild:
Restricting python
@@ -99,4 +105,3 @@
14 Nov 2004; Lukasz Strzygowski <lucass@gentoo.org> +metadata.xml,
+files/drpython.py-3.6.10.patch, +drpython-3.6.10.ebuild:
Initial import. Closing #55370. Thanks for help to Rob Cakebread.
-
diff --git a/dev-python/drpython/drpython-3.11.4.ebuild b/dev-python/drpython/drpython-3.11.4.ebuild
new file mode 100644
index 000000000000..79b87aa64abf
--- /dev/null
+++ b/dev-python/drpython/drpython-3.11.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/drpython/drpython-3.11.4.ebuild,v 1.1 2014/05/04 11:41:05 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="DrPython"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="A powerful cross-platform IDE for Python"
+HOMEPAGE="http://drpython.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/wxpython-2.6"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+PAYTCHES=( "${FILESDIR}/${PN}-165-wxversion.patch" )
+
+python_prepare_all() {
+ sed \
+ -e "/'drpython.pyw', 'drpython.lin'/d" \
+ -e "/scripts=\['postinst.py'\],/d" \
+ -i setup.py || die "sed failed"
+ sed -e "s/arguments)c/arguments)/" -i examples/DrScript/SetTerminalArgs.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ make_wrapper drpython "${PYTHON}" $(python_get_sitedir)/${PN}/drpython.py
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ elog "DrPython plugins are available on DrPython homepage:"
+ elog "http://sourceforge.net/projects/drpython/files/DrPython%20Plugins/"
+}
diff --git a/dev-python/drpython/files/drpython-165-wxversion.patch b/dev-python/drpython/files/drpython-165-wxversion.patch
index 5fb798805c3c..bab247c2110c 100644
--- a/dev-python/drpython/files/drpython-165-wxversion.patch
+++ b/dev-python/drpython/files/drpython-165-wxversion.patch
@@ -1,6 +1,6 @@
diff -Naur drpython-orig/drpython_wx26.py drpython/drpython_wx26.py
---- drpython-orig/drpython_wx26.py 2007-03-23 19:20:02.000000000 -0600
-+++ drpython/drpython_wx26.py 2007-12-03 18:36:01.000000000 -0600
+--- drpython_wx26.py 2007-03-23 19:20:02.000000000 -0600
++++ drpython_wx26.py 2007-12-03 18:36:01.000000000 -0600
@@ -34,7 +34,7 @@
## testfile for older version