summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2013-09-15 10:56:08 +0000
committerDirkjan Ochtman <djc@gentoo.org>2013-09-15 10:56:08 +0000
commitff1c923d0ff362f1bfcb40b6c45df18c8c6fd191 (patch)
treead32c9d2762af04092bf7a120ac80cd2d447991d /dev-python/django
parentVersion bump django to 1.4.8. (diff)
downloadgentoo-2-ff1c923d0ff362f1bfcb40b6c45df18c8c6fd191.tar.gz
gentoo-2-ff1c923d0ff362f1bfcb40b6c45df18c8c6fd191.tar.bz2
gentoo-2-ff1c923d0ff362f1bfcb40b6c45df18c8c6fd191.zip
Remove old versions.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 6B065BFB)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog7
-rw-r--r--dev-python/django/django-1.3.2.ebuild111
-rw-r--r--dev-python/django/django-1.3.4.ebuild111
-rw-r--r--dev-python/django/django-1.4.1.ebuild109
-rw-r--r--dev-python/django/django-1.4.2-r2.ebuild91
-rw-r--r--dev-python/django/django-1.4.2.ebuild109
-rw-r--r--dev-python/django/django-1.5-r1.ebuild84
7 files changed, 6 insertions, 616 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index c09e45ba03a7..0bf943f7203d 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.113 2013/09/15 10:53:27 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.114 2013/09/15 10:56:08 djc Exp $
+
+ 15 Sep 2013; Dirkjan Ochtman <djc@gentoo.org> -django-1.3.2.ebuild,
+ -django-1.3.4.ebuild, -django-1.4.1.ebuild, -django-1.4.2-r2.ebuild,
+ -django-1.4.2.ebuild, -django-1.5-r1.ebuild:
+ Remove old versions.
*django-1.4.8 (15 Sep 2013)
diff --git a/dev-python/django/django-1.3.2.ebuild b/dev-python/django/django-1.3.2.ebuild
deleted file mode 100644
index 841c87091426..000000000000
--- a/dev-python/django/django-1.3.2.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.3.2.ebuild,v 1.4 2013/06/09 17:14:47 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion-r1 distutils eutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="virtual/python-imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.3 )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="docs/README AUTHORS"
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-1.3.1-djangodocs_extension.patch"
-
- # Disable tests requiring network connection.
- sed \
- -e "s/test_correct_url_value_passes/_&/" \
- -e "s/test_correct_url_with_redirect/_&/" \
- -i tests/modeltests/validation/tests.py
- sed \
- -e "s/test_urlfield_3/_&/" \
- -e "s/test_urlfield_4/_&/" \
- -e "s/test_urlfield_10/_&/" \
- -i tests/regressiontests/forms/tests/fields.py
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- newbashcomp extras/django_bash_completion ${PN} || die
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/media/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.3.4.ebuild b/dev-python/django/django-1.3.4.ebuild
deleted file mode 100644
index 10f296568248..000000000000
--- a/dev-python/django/django-1.3.4.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.3.4.ebuild,v 1.3 2013/06/09 17:14:47 floppym Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-PYTHON_TESTS_RESTRICTED_ABIS="2.[56] 2.7-pypy-1.*"
-inherit bash-completion-r1 distutils eutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="virtual/python-imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.3 )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS="docs/README AUTHORS"
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_prepare() {
- distutils_src_prepare
- epatch "${FILESDIR}/${PN}-1.3.1-djangodocs_extension.patch"
-
- # Disable tests requiring network connection.
- sed \
- -e "s/test_correct_url_value_passes/_&/" \
- -e "s/test_correct_url_with_redirect/_&/" \
- -i tests/modeltests/validation/tests.py
- sed \
- -e "s/test_urlfield_3/_&/" \
- -e "s/test_urlfield_4/_&/" \
- -e "s/test_urlfield_10/_&/" \
- -i tests/regressiontests/forms/tests/fields.py
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- newbashcomp extras/django_bash_completion ${PN}
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/*
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/media/*
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.4.1.ebuild b/dev-python/django/django-1.4.1.ebuild
deleted file mode 100644
index 3541fb35c5a9..000000000000
--- a/dev-python/django/django-1.4.1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.4.1.ebuild,v 1.4 2013/06/09 17:14:46 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit bash-completion-r1 distutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="virtual/python-imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg:2 )
- mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-0.3 )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable tests requiring network connection.
- sed \
- -e "s/test_correct_url_value_passes/_&/" \
- -e "s/test_correct_url_with_redirect/_&/" \
- -i tests/modeltests/validation/tests.py
- sed \
- -e "s/test_urlfield_3/_&/" \
- -e "s/test_urlfield_4/_&/" \
- -e "s/test_urlfield_10/_&/" \
- -i tests/regressiontests/forms/tests/fields.py
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html || die "Generation of documentation failed"
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- newbashcomp extras/django_bash_completion ${PN} || die
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/static/admin/* || die "doins failed"
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.4.2-r2.ebuild b/dev-python/django/django-1.4.2-r2.ebuild
deleted file mode 100644
index 30e4f2585eb4..000000000000
--- a/dev-python/django/django-1.4.2-r2.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.4.2-r2.ebuild,v 1.3 2013/09/05 18:46:06 mgorny Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-PYTHON_REQ_USE='sqlite?'
-
-inherit bash-completion-r1 distutils-r1 versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="virtual/python-imaging[${PYTHON_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- mysql? ( >=dev-python/mysql-python-1.2.3[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
- test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-python_prepare_all() {
- # Disable tests requiring network connection.
- sed \
- -e "s/test_correct_url_value_passes/_&/" \
- -e "s/test_correct_url_with_redirect/_&/" \
- -i tests/modeltests/validation/tests.py || die
- sed \
- -e "s/test_urlfield_3/_&/" \
- -e "s/test_urlfield_4/_&/" \
- -e "s/test_urlfield_10/_&/" \
- -i tests/regressiontests/forms/tests/fields.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- PYTHONPATH=. \
- "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-src_install() {
- distutils-r1_src_install
- webapp_src_install
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- newbashcomp extras/django_bash_completion ${PN}
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/.
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/static/admin/.
-}
-
-pkg_postinst() {
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- elog
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
-
- # XXX: call webapp_pkg_postinst? the old ebuild didn't do that...
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.4.2.ebuild b/dev-python/django/django-1.4.2.ebuild
deleted file mode 100644
index 30c33dee7560..000000000000
--- a/dev-python/django/django-1.4.2.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.4.2.ebuild,v 1.2 2013/06/09 17:14:46 floppym Exp $
-
-EAPI="4"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-PYTHON_TESTS_RESTRICTED_ABIS="2.6" # fails with 1 single Error
-
-inherit bash-completion-r1 distutils versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-RDEPEND="virtual/python-imaging
- sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
- postgres? ( dev-python/psycopg:2 )
- mysql? ( >=dev-python/mysql-python-1.2.3 )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.7 )
- test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-pkg_setup() {
- python_pkg_setup
- webapp_pkg_setup
-}
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable tests requiring network connection.
- sed \
- -e "s/test_correct_url_value_passes/_&/" \
- -e "s/test_correct_url_with_redirect/_&/" \
- -i tests/modeltests/validation/tests.py || die
- sed \
- -e "s/test_urlfield_3/_&/" \
- -e "s/test_urlfield_4/_&/" \
- -e "s/test_urlfield_10/_&/" \
- -i tests/regressiontests/forms/tests/fields.py || die
-}
-
-src_compile() {
- distutils_src_compile
- if use doc; then
- einfo "Generation of documentation"
- pushd docs > /dev/null
- emake html
- popd > /dev/null
- fi
-}
-
-src_test() {
- testing() {
- # Tests have non-standard assumptions about PYTHONPATH and
- # don't work with usual "build-${PYTHON_ABI}/lib".
- PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- newbashcomp extras/django_bash_completion ${PN}
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/*
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/static/admin/*
-
- webapp_src_install
-}
-
-pkg_preinst() {
- :
-}
-
-pkg_postinst() {
- distutils_pkg_postinst
-
- einfo "Now, Django has the best of both worlds with Gentoo,"
- einfo "ease of deployment for production and development."
- echo
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- echo
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}
diff --git a/dev-python/django/django-1.5-r1.ebuild b/dev-python/django/django-1.5-r1.ebuild
deleted file mode 100644
index 4abec3020edb..000000000000
--- a/dev-python/django/django-1.5-r1.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.5-r1.ebuild,v 1.3 2013/06/09 17:14:46 floppym Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_REQ_USE='sqlite?'
-
-inherit bash-completion-r1 distutils-r1 versionator webapp
-
-MY_P="Django-${PV}"
-
-DESCRIPTION="High-level Python web framework"
-HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
-SRC_URI="https://www.djangoproject.com/m/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc mysql postgres sqlite test"
-
-PY2_USEDEP=$(python_gen_usedep 'python2*')
-RDEPEND="virtual/python-imaging[${PY2_USEDEP}]
- postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
- mysql? ( >=dev-python/mysql-python-1.2.3[${PY2_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( >=dev-python/sphinx-1.0.7[${PYTHON_USEDEP}] )
- test? ( ${PYTHON_DEPS//sqlite?/sqlite} )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBAPP_MANUAL_SLOT="yes"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-PATCHES=( "${FILESDIR}"/${P}-py3tests.patch \
- "${FILESDIR}"/${P}-objects.patch )
-
-python_test() {
- # Tests have non-standard assumptions about PYTHONPATH,
- # and don't work with ${BUILD_DIR}/lib.
- PYTHONPATH=. \
- "${PYTHON}" tests/runtests.py --settings=test_sqlite -v1 \
- || die "Tests fail with ${EPYTHON}"
-}
-
-src_test() {
- # Port conflict in django.test.testcases.LiveServerTestCase.
- # Several other races with temp files.
- DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
-}
-
-src_install() {
- distutils-r1_src_install
- webapp_src_install
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- newbashcomp extras/django_bash_completion ${PN}
-
- if use doc; then
- rm -fr docs/_build/html/_sources
- dohtml -A txt -r docs/_build/html/.
- fi
-
- insinto "${MY_HTDOCSDIR#${EPREFIX}}"
- doins -r django/contrib/admin/static/admin/.
-}
-
-pkg_postinst() {
- elog "A copy of the admin media is available to"
- elog "webapp-config for installation in a webroot,"
- elog "as well as the traditional location in python's"
- elog "site-packages dir for easy development"
- elog
- ewarn "If you build Django ${PV} without USE=\"vhosts\""
-
- # XXX: call webapp_pkg_postinst? the old ebuild didn't do that...
- ewarn "webapp-config will automatically install the"
- ewarn "admin media into the localhost webroot."
-}