summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-04-01 05:29:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-04-01 05:29:36 +0000
commitbdec28a08e30e54307f2da5a4570d11bd5c65ee0 (patch)
tree4f4b0ae9ec1579a1d3b645c58817391ee34825d6 /dev-python/django
parentDisable build of matlab plugin per default, #410211 (diff)
downloadgentoo-2-bdec28a08e30e54307f2da5a4570d11bd5c65ee0.tar.gz
gentoo-2-bdec28a08e30e54307f2da5a4570d11bd5c65ee0.tar.bz2
gentoo-2-bdec28a08e30e54307f2da5a4570d11bd5c65ee0.zip
Bump for #409527
(Portage version: 2.2.0_alpha97/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/ChangeLog9
-rw-r--r--dev-python/django/django-1.4.ebuild113
2 files changed, 120 insertions, 2 deletions
diff --git a/dev-python/django/ChangeLog b/dev-python/django/ChangeLog
index cabbe0a28760..0923c6fd60e5 100644
--- a/dev-python/django/ChangeLog
+++ b/dev-python/django/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/django
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.77 2011/12/21 07:06:46 floppym Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/ChangeLog,v 1.78 2012/04/01 05:29:36 patrick Exp $
+
+*django-1.4 (01 Apr 2012)
+
+ 01 Apr 2012; Patrick Lauer <patrick@gentoo.org> +django-1.4.ebuild:
+ Bump for #409527
21 Dec 2011; Mike Gilbert <floppym@gentoo.org>
+files/django-1.3.1-djangodocs_extension.patch, django-1.3.1-r1.ebuild,
diff --git a/dev-python/django/django-1.4.ebuild b/dev-python/django/django-1.4.ebuild
new file mode 100644
index 000000000000..ea2523752e76
--- /dev/null
+++ b/dev-python/django/django-1.4.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django/django-1.4.ebuild,v 1.1 2012/04/01 05:29:36 patrick Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit bash-completion-r1 distutils eutils versionator webapp
+
+MY_P="Django-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="http://www.djangoproject.com/ http://pypi.python.org/pypi/Django"
+#SRC_URI="http://media.djangoproject.com/releases/$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+SRC_URI="http://www.djangoproject.com/download/1.4/tarball/ -> ${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc mysql postgres sqlite test"
+
+RDEPEND="dev-python/imaging
+ sqlite? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )
+ postgres? ( dev-python/psycopg )
+ mysql? ( >=dev-python/mysql-python-1.2.1_p2 )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-python/sphinx-0.3 )
+ test? ( || ( dev-lang/python:2.7[sqlite] dev-lang/python:2.6[sqlite] dev-lang/python:2.5[sqlite] dev-python/pysqlite:2 ) )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="docs/README AUTHORS"
+WEBAPP_MANUAL_SLOT="yes"
+
+pkg_setup() {
+ python_pkg_setup
+ webapp_pkg_setup
+}
+
+src_prepare() {
+ distutils_src_prepare
+ #epatch "${FILESDIR}/${P}-djangodocs_extension.patch"
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/test_correct_url_value_passes/_&/" \
+ -e "s/test_correct_url_with_redirect/_&/" \
+ -i tests/modeltests/validation/tests.py
+ sed \
+ -e "s/test_urlfield_3/_&/" \
+ -e "s/test_urlfield_4/_&/" \
+ -e "s/test_urlfield_10/_&/" \
+ -i tests/regressiontests/forms/tests/fields.py
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ pushd docs > /dev/null
+ emake html || die "Generation of documentation failed"
+ popd > /dev/null
+ fi
+}
+
+src_test() {
+ testing() {
+ # Tests have non-standard assumptions about PYTHONPATH and
+ # don't work with usual "build-${PYTHON_ABI}/lib".
+ PYTHONPATH="." "$(PYTHON)" tests/runtests.py --settings=test_sqlite -v1
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ newbashcomp extras/django_bash_completion ${PN} || die
+
+ if use doc; then
+ rm -fr docs/_build/html/_sources
+ dohtml -A txt -r docs/_build/html/* || die "dohtml failed"
+ fi
+
+ insinto "${MY_HTDOCSDIR#${EPREFIX}}"
+ # gone
+ #doins -r django/contrib/admin/media/* || die "doins failed"
+
+ webapp_src_install
+}
+
+pkg_preinst() {
+ :
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ einfo "Now, Django has the best of both worlds with Gentoo,"
+ einfo "ease of deployment for production and development."
+ echo
+ elog "A copy of the admin media is available to"
+ elog "webapp-config for installation in a webroot,"
+ elog "as well as the traditional location in python's"
+ elog "site-packages dir for easy development"
+ echo
+ ewarn "If you build Django ${PV} without USE=\"vhosts\""
+ ewarn "webapp-config will automatically install the"
+ ewarn "admin media into the localhost webroot."
+}