summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-12 10:56:16 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-12 10:56:16 +0000
commit389602ba192a28e1fb1e77d71663ed7e594b6024 (patch)
tree364501bda374716dcdb56bda9ec4993d72855bf2 /dev-python/django-pipeline
parentexport PKG_CONFIG as well (diff)
downloadgentoo-2-389602ba192a28e1fb1e77d71663ed7e594b6024.tar.gz
gentoo-2-389602ba192a28e1fb1e77d71663ed7e594b6024.tar.bz2
gentoo-2-389602ba192a28e1fb1e77d71663ed7e594b6024.zip
Version bump. Clean up and fix the ebuild (plus fix using wrapping internals, wrt bug #484408). Drop old.
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-python/django-pipeline')
-rw-r--r--dev-python/django-pipeline/ChangeLog10
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.6.ebuild66
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.11.ebuild59
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.15.ebuild45
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.3.9.ebuild63
5 files changed, 54 insertions, 189 deletions
diff --git a/dev-python/django-pipeline/ChangeLog b/dev-python/django-pipeline/ChangeLog
index cc3f0b98009e..c77eab84d1e3 100644
--- a/dev-python/django-pipeline/ChangeLog
+++ b/dev-python/django-pipeline/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/django-pipeline
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.15 2013/06/04 16:28:45 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/ChangeLog,v 1.16 2013/09/12 10:56:16 mgorny Exp $
+
+*django-pipeline-1.3.15 (12 Sep 2013)
+
+ 12 Sep 2013; Michał Górny <mgorny@gentoo.org> +django-pipeline-1.3.15.ebuild,
+ -django-pipeline-1.2.6.ebuild, -django-pipeline-1.3.11.ebuild,
+ -django-pipeline-1.3.9.ebuild:
+ Version bump. Clean up and fix the ebuild (plus fix using wrapping internals,
+ wrt bug #484408). Drop old.
04 Jun 2013; Mike Gilbert <floppym@gentoo.org> django-pipeline-1.3.11.ebuild:
Fix typo.
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
deleted file mode 100644
index 7d164dc72ca6..000000000000
--- a/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild,v 1.2 2013/01/21 05:46:14 idella4 Exp $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit distutils
-
-DESCRIPTION="An asset packaging library for Django"
-HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-LICENSE="MIT"
-SLOT="0"
-PYTHON_MODNAME="pipeline"
-DISTUTILS_SRC_TEST=nosetests
-RDEPEND=">=dev-python/django-1.4"
-DEPEND="${RDEPEND}
- dev-python/setuptools"
-
-src_compile() {
- use doc && emake -C docs html
- rm -f docs/_build/doctrees/environment.pickle || die
- distutils_src_compile
-}
-
-src_test() {
- export DJANGO_SETTINGS_MODULE="django.conf"
- # Python.[56] trigger a harmless deprecation warning
- testing() {
- local exit_status=0 test
- pushd build-${PYTHON_ABI}/lib/tests/tests/ > /dev/null || die
- for test in [a-z]*.py
- do
- if ! "$(PYTHON)" ${test}; then
- eerror "test "${test}" failed"
- exit_status="1"
- else
- einfo "test "${test}" passed OK"
- fi
- done
- popd > /dev/null
- return ${exit_status}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/_build/html/
- fi
-
- # Remove un-needed tests to avoid file collisions
- rmtests() {
- rm -rf "${ED}"/$(python_get_sitedir)/tests/ || die
- }
-
- python_execute_function rmtests
-}
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.11.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.11.ebuild
deleted file mode 100644
index 580af3712135..000000000000
--- a/dev-python/django-pipeline/django-pipeline-1.3.11.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.11.ebuild,v 1.2 2013/06/04 16:28:45 floppym Exp $
-
-EAPI=5
-# There's doubt in py3.2's readiness
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="An asset packaging library for Django"
-HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/ https://github.com/cyberdelia/django-pipeline"
-SRC_URI="https://github.com/cyberdelia/django-pipeline/archive/1.3.11.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/django-1.4.1[${PYTHON_USEDEP}]
- dev-python/futures[$(python_gen_usedep python{2_6,2_7})]
- dev-python/jsmin[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare() {
- use test && DISTUTILS_IN_SOURCE_BUILD=1
- distutils_python_prepare
-}
-
-python_compile_all() {
- use doc && emake -C docs html
- rm -f docs/_build/doctrees/environment.pickle || die
-}
-
-python_compile() {
- # Need remove tests before reaching distutils-r1_src_install
- if ! use test; then
- rm -rf tests/ || die
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- export DJANGO_SETTINGS_MODULE="django.conf"
- pushd "${BUILD_DIR}"/lib/tests/ &> /dev/null
- ln -sf ../../../tests/assets . || die
- ln -sf ../../../tests/assets2 . || die
- cd ../../../ || die
- django-admin.py-${EPYTHON} test --settings=tests.settings tests \
- || die "Tests failed under ${EPYTHON}"
- rm -rf tests/ || die
- rm -rf "${S}"/tests/ || einfo "tests folder already removed"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild
new file mode 100644
index 000000000000..b7fafb09fb72
--- /dev/null
+++ b/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.15.ebuild,v 1.1 2013/09/12 10:56:16 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="An asset packaging library for Django"
+HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/ https://github.com/cyberdelia/django-pipeline"
+
+# PyPi releases lack docs/ subdir:
+# https://github.com/cyberdelia/django-pipeline/pull/254
+SRC_URI="https://github.com/cyberdelia/django-pipeline/archive/${PV}.tar.gz -> ${P}-gh.tar.gz"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/django-1.4.1[${PYTHON_USEDEP}]
+ dev-python/futures[$(python_gen_usedep python{2_6,2_7})]
+ dev-python/jsmin[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ export DJANGO_SETTINGS_MODULE="django.conf"
+ cp -r tests "${BUILD_DIR}"/ || die
+ PYTHONPATH=${BUILD_DIR}:${PYTHONPATH} \
+ django-admin.py test --settings=tests.settings tests \
+ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/django-pipeline/django-pipeline-1.3.9.ebuild b/dev-python/django-pipeline/django-pipeline-1.3.9.ebuild
deleted file mode 100644
index f6efc4939461..000000000000
--- a/dev-python/django-pipeline/django-pipeline-1.3.9.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/django-pipeline/django-pipeline-1.3.9.ebuild,v 1.5 2013/05/31 16:21:20 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="An asset packaging library for Django"
-HOMEPAGE="http://pypi.python.org/pypi/django-pipeline/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/django-1.4.1[${PYTHON_USEDEP}]
- dev-python/futures[$(python_gen_usedep python{2_6,2_7})]
- dev-python/jsmin[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-# Test phase unworkable due to missing source content
-RESTRICT="test"
-
-python_compile_all() {
- use doc && emake -C docs html
- rm -f docs/_build/doctrees/environment.pickle || die
-}
-
-python_compile() {
- # Need remove tests before reaching distutils-r1_src_install
- if ! use test; then
- rm -rf tests/ || die
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- export DJANGO_SETTINGS_MODULE="django.conf"
- export SECRET_KEY='green'
- local test
- pushd "${BUILD_DIR}"/lib/tests/tests/ > /dev/null || die
- for test in test_*.py
- do
- if ! "${PYTHON}" -c \
- "from django.conf import global_settings;global_settings.SECRET_KEY='$SECRET_KEY'" ${test}
- then
- die "test ${test} failed under ${EPYTHON}"
- else
- einfo "test ${test} passed under ${EPYTHON}"
- fi
- done
- cd ../../
- rm -rf tests/ || die
- rm -rf "${S}"/tests/ || einfo "tests folder already removed"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}