summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-27 17:01:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-27 17:01:55 +0000
commit352d5765c2e526d30178278554cdb52ebe8411ab (patch)
treef93d75f39428427d2b1b16c2784e77d667a697cd /dev-python/decorator
parentFixing ChangeLog (diff)
downloadgentoo-2-352d5765c2e526d30178278554cdb52ebe8411ab.tar.gz
gentoo-2-352d5765c2e526d30178278554cdb52ebe8411ab.tar.bz2
gentoo-2-352d5765c2e526d30178278554cdb52ebe8411ab.zip
Set PYTHON_MODNAME.
Diffstat (limited to 'dev-python/decorator')
-rw-r--r--dev-python/decorator/decorator-3.1.2.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/dev-python/decorator/decorator-3.1.2.ebuild b/dev-python/decorator/decorator-3.1.2.ebuild
index 78edef197e75..0e49bdcbf0fb 100644
--- a/dev-python/decorator/decorator-3.1.2.ebuild
+++ b/dev-python/decorator/decorator-3.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-3.1.2.ebuild,v 1.7 2010/05/20 07:52:23 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/decorator/decorator-3.1.2.ebuild,v 1.8 2010/05/27 17:01:55 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -18,10 +18,10 @@ IUSE="doc"
DEPEND=""
RDEPEND=""
-
-RESTRICT_PYTHON_ABIS="3*"
+RESTRICT_PYTHON_ABIS="3.*"
DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="decorator.py"
src_test() {
# multiprocessing module is available only in Python >=2.6, and isn't used anyway.
@@ -39,11 +39,3 @@ src_install() {
dohtml documentation.html || die "dohtml html doc failed"
fi
}
-
-pkg_postinst() {
- python_mod_optimize decorator.py
-}
-
-pkg_postrm() {
- python_mod_cleanup
-}