summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-06-03 04:14:09 +0000
committerIan Delaney <idella4@gentoo.org>2015-06-03 04:14:09 +0000
commit7e1639b2e90d31848db8ecda8a367468e8a33868 (patch)
treec7f284d9dcee1aca6f163d2ee1930a2cf13bd28c /dev-python/cytoolz
parentppc stable wrt bug #543564 (diff)
downloadgentoo-2-7e1639b2e90d31848db8ecda8a367468e8a33868.tar.gz
gentoo-2-7e1639b2e90d31848db8ecda8a367468e8a33868.tar.bz2
gentoo-2-7e1639b2e90d31848db8ecda8a367468e8a33868.zip
bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/cytoolz')
-rw-r--r--dev-python/cytoolz/ChangeLog7
-rw-r--r--dev-python/cytoolz/cytoolz-0.7.3.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/cytoolz/ChangeLog b/dev-python/cytoolz/ChangeLog
index 317c491d05c1..7e7c47e23bb5 100644
--- a/dev-python/cytoolz/ChangeLog
+++ b/dev-python/cytoolz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cytoolz
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cytoolz/ChangeLog,v 1.9 2015/03/20 05:29:12 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cytoolz/ChangeLog,v 1.10 2015/06/03 04:14:09 idella4 Exp $
+
+*cytoolz-0.7.3 (03 Jun 2015)
+
+ 03 Jun 2015; Ian Delaney <idella4@gentoo.org> +cytoolz-0.7.3.ebuild:
+ bump
20 Mar 2015; Ian Delaney <idella4@gentoo.org> cytoolz-0.7.2-r2.ebuild:
shift toolz as a dep for tests, from info from package's author
diff --git a/dev-python/cytoolz/cytoolz-0.7.3.ebuild b/dev-python/cytoolz/cytoolz-0.7.3.ebuild
new file mode 100644
index 000000000000..803172e59dd9
--- /dev/null
+++ b/dev-python/cytoolz/cytoolz-0.7.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cytoolz/cytoolz-0.7.3.ebuild,v 1.1 2015/06/03 04:14:09 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Cython implementation of Toolz: High performance functional utilities"
+HOMEPAGE="https://pypi.python.org/pypi/cytoolz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# Informed by author the dep in toolz is not only required but the
+# tests are version sensitive.
+# https://github.com/pytoolz/cytoolz/issues/57
+RDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/toolz-0.7.1[${PYTHON_USEDEP}] )"
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+
+ distutils-r1_python_compile
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib/ > /dev/null
+ PYTHONPATH=.:${PN} nosetests --with-doctest ${PN} || die "tests failed under ${EPYTHON}"
+ popd > /dev/null
+}