summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-09-10 19:08:36 +0000
committerMike Gilbert <floppym@gentoo.org>2011-09-10 19:08:36 +0000
commitc8f7f0edcd32e71866d7d4672fc512df62bd9e1d (patch)
tree3006a0afeb16f83660a1a1913cbe9c8b3f766c60 /dev-python/cherrypy
parentVersion bump. (diff)
downloadgentoo-2-c8f7f0edcd32e71866d7d4672fc512df62bd9e1d.tar.gz
gentoo-2-c8f7f0edcd32e71866d7d4672fc512df62bd9e1d.tar.bz2
gentoo-2-c8f7f0edcd32e71866d7d4672fc512df62bd9e1d.zip
Version bump for bug 381985 by Johan Bergström. Drop support for py2.4.
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/cherrypy')
-rw-r--r--dev-python/cherrypy/ChangeLog7
-rw-r--r--dev-python/cherrypy/cherrypy-3.2.1.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-python/cherrypy/ChangeLog b/dev-python/cherrypy/ChangeLog
index e96f2e4403f7..42feaf6cd0f4 100644
--- a/dev-python/cherrypy/ChangeLog
+++ b/dev-python/cherrypy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/cherrypy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.45 2011/04/23 18:16:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/ChangeLog,v 1.46 2011/09/10 19:08:36 floppym Exp $
+
+*cherrypy-3.2.1 (10 Sep 2011)
+
+ 10 Sep 2011; Mike Gilbert <floppym@gentoo.org> +cherrypy-3.2.1.ebuild:
+ Version bump for bug 381985 by Johan Bergström. Drop support for py2.4.
23 Apr 2011; Raúl Porcel <armin76@gentoo.org> cherrypy-3.2.0.ebuild:
ia64 stable wrt #361151
diff --git a/dev-python/cherrypy/cherrypy-3.2.1.ebuild b/dev-python/cherrypy/cherrypy-3.2.1.ebuild
new file mode 100644
index 000000000000..6fdda888c4f7
--- /dev/null
+++ b/dev-python/cherrypy/cherrypy-3.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cherrypy/cherrypy-3.2.1.ebuild,v 1.1 2011/09/10 19:08:36 floppym Exp $
+
+EAPI="3"
+PYTHON_DEPEND="*:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+MY_P="CherryPy-${PV}"
+
+DESCRIPTION="CherryPy is a pythonic, object-oriented HTTP framework"
+HOMEPAGE="http://www.cherrypy.org/ http://pypi.python.org/pypi/CherryPy"
+SRC_URI="http://download.cherrypy.org/${PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ distutils_src_prepare
+ sed -i \
+ -e 's/"cherrypy.tutorial", //' \
+ -e "/('cherrypy\/tutorial',/,/),/d" \
+ -e "/LICENSE.txt/d" \
+ setup.py || die "sed failed"
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/cherrypy/test"
+ }
+ python_execute_function -q delete_tests
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r cherrypy/tutorial || die "Installation of documentation failed"
+ fi
+}