summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-18 12:18:55 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-18 12:18:55 +0000
commit5a8e4ae67a7be9751832dd61dce61701bfc8331f (patch)
tree24c7be48a738d9f3d1330e6bcbfb5e673c016fe5 /dev-python/cheetah
parentversion bump (bug 38346) (diff)
downloadgentoo-2-5a8e4ae67a7be9751832dd61dce61701bfc8331f.tar.gz
gentoo-2-5a8e4ae67a7be9751832dd61dce61701bfc8331f.tar.bz2
gentoo-2-5a8e4ae67a7be9751832dd61dce61701bfc8331f.zip
moving from dev-python/Cheetah to dev-python/cheetah
Diffstat (limited to 'dev-python/cheetah')
-rw-r--r--dev-python/cheetah/ChangeLog50
-rw-r--r--dev-python/cheetah/cheetah-0.9.14.ebuild27
-rw-r--r--dev-python/cheetah/cheetah-0.9.15.ebuild29
-rw-r--r--dev-python/cheetah/files/digest-cheetah-0.9.141
-rw-r--r--dev-python/cheetah/files/digest-cheetah-0.9.151
-rw-r--r--dev-python/cheetah/metadata.xml5
6 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/cheetah/ChangeLog b/dev-python/cheetah/ChangeLog
new file mode 100644
index 000000000000..326fe1a12f71
--- /dev/null
+++ b/dev-python/cheetah/ChangeLog
@@ -0,0 +1,50 @@
+# ChangeLog for dev-python/cheetah
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/ChangeLog,v 1.1 2004/01/18 12:18:55 liquidx Exp $
+
+ 18 Jan 2004; Alastair Tse <liquidx@gentoo.org> cheetah-0.9.14.ebuild,
+ cheetah-0.9.15.ebuild, metadata.xml:
+ moving from dev-python/Cheetah to dev-python/cheetah
+
+ 12 Jul 2003; Daniel Ahlberg <aliz@gentoo.org> :
+ Added missing changelog entry.
+
+*Cheetah-0.9.15 (04 Apr 2003)
+
+ 22 May 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Marking stable on ~x86.
+
+ 04 Apr 2003; Alastair Tse <liquidx@gentoo.org> Cheetah-0.9.15.ebuild:
+ version bump
+
+*Cheetah-0.9.15 (28 Jan 2003)
+
+ 28 Jan 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Updated to version 0.9.15a3.
+ Sanified the ChangeLog.
+
+*Cheetah-0.9.14 (13 Aug 2002)
+
+ 13 Aug 2002; Joachim Blaabjerg <styx@gentoo.org> Cheetah-0.9.14.ebuild :
+ Version bump.
+
+*Cheetah-0.9.13 (03 Jun 2002)
+
+ 26 Jul 2002; George Shapovalov <george@gentoo.org> Cheetah-0.9.13.ebuild :
+ added KEYWORDS
+
+ 03 Jun 2002; George Shapovalov <george@gentoo.org> Cheetah-0.9.13.ebuild,
+ files/digest-Cheetah-0.9.13 :
+
+ First submission
+ From the ebuild author:
+
+ Cheetah is a Python-powered template engine and code generator. It may be used
+ as a standalone utility or combined with other tools. Cheetah has many potential
+ uses, but web developers looking for a viable alternative to ASP, JSP, PHP and
+ PSP are expected to be its principle user group.
+
+ http://www.cheetahtemplate.org/ for more info.
+
+ Ebuild submitted by Jason Jeremias <jason@penguinsolutions.com>.
+
diff --git a/dev-python/cheetah/cheetah-0.9.14.ebuild b/dev-python/cheetah/cheetah-0.9.14.ebuild
new file mode 100644
index 000000000000..74942969dc34
--- /dev/null
+++ b/dev-python/cheetah/cheetah-0.9.14.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/cheetah-0.9.14.ebuild,v 1.1 2004/01/18 12:18:55 liquidx Exp $
+
+inherit distutils
+
+MY_P=${P/ch/Ch}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Cheetah is a Python-powered template engine and code generator."
+SRC_URI="mirror://sourceforge/cheetahtemplate/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cheetahtemplate.org/"
+
+RDEPEND=">=dev-lang/python-2.2"
+DEPEND="${RDEPEND}"
+
+SLOT="0"
+KEYWORDS="x86 sparc alpha"
+LICENSE="PSF-2.2"
+IUSE=""
+
+src_install() {
+ DOCS="README CHANGES PKG-INFO LICENSE TODO"
+ distutils_src_install
+ dodir /usr/share/doc/${PF}
+ cp -R ${S}/examples ${D}/usr/share/doc/${PF}/
+}
+
diff --git a/dev-python/cheetah/cheetah-0.9.15.ebuild b/dev-python/cheetah/cheetah-0.9.15.ebuild
new file mode 100644
index 000000000000..02f89daca668
--- /dev/null
+++ b/dev-python/cheetah/cheetah-0.9.15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/cheetah/cheetah-0.9.15.ebuild,v 1.1 2004/01/18 12:18:55 liquidx Exp $
+
+inherit distutils
+
+MY_P="${P/ch/Ch}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Python-powered template engine and code generator."
+HOMEPAGE="http://www.cheetahtemplate.org/"
+SRC_URI="mirror://sourceforge/cheetahtemplate/${MY_P}.tar.gz"
+
+LICENSE="PSF-2.2"
+IUSE=""
+KEYWORDS="x86 ~sparc ~alpha"
+SLOT="0"
+
+RDEPEND=">=dev-lang/python-2.2"
+DEPEND="${RDEPEND}"
+
+PYTHON_MODNAME="Cheetah"
+
+src_install() {
+ DOCS="README CHANGES LICENSE TODO"
+ distutils_src_install
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/webware_examples/cheetahSite/*
+}
diff --git a/dev-python/cheetah/files/digest-cheetah-0.9.14 b/dev-python/cheetah/files/digest-cheetah-0.9.14
new file mode 100644
index 000000000000..b030aa7244f8
--- /dev/null
+++ b/dev-python/cheetah/files/digest-cheetah-0.9.14
@@ -0,0 +1 @@
+MD5 500a4fa02250836cb65b87e029512cf0 Cheetah-0.9.14.tar.gz 581582
diff --git a/dev-python/cheetah/files/digest-cheetah-0.9.15 b/dev-python/cheetah/files/digest-cheetah-0.9.15
new file mode 100644
index 000000000000..4fad3be6e901
--- /dev/null
+++ b/dev-python/cheetah/files/digest-cheetah-0.9.15
@@ -0,0 +1 @@
+MD5 319ec904e002da97061d58eadd72fa5c Cheetah-0.9.15.tar.gz 621628
diff --git a/dev-python/cheetah/metadata.xml b/dev-python/cheetah/metadata.xml
new file mode 100644
index 000000000000..de483c53568f
--- /dev/null
+++ b/dev-python/cheetah/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+</pkgmetadata>