summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-09-26 12:05:16 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-09-26 12:05:16 +0000
commit2989880b8810c9d205008591b072d7c9f9d1ac9d (patch)
tree35dfceb567d5ded65e92b1e418bf3bb233f7d2e6 /dev-python/bsddb3
parentbug 65316 (Manifest recommit) (diff)
downloadgentoo-2-2989880b8810c9d205008591b072d7c9f9d1ac9d.tar.gz
gentoo-2-2989880b8810c9d205008591b072d7c9f9d1ac9d.tar.bz2
gentoo-2-2989880b8810c9d205008591b072d7c9f9d1ac9d.zip
fix problems with 4.2 incompatibility with bsddb3-4.1.3 (#62017)
Diffstat (limited to 'dev-python/bsddb3')
-rw-r--r--dev-python/bsddb3/ChangeLog7
-rw-r--r--dev-python/bsddb3/bsddb3-4.1.3.ebuild10
-rw-r--r--dev-python/bsddb3/bsddb3-4.2.4.ebuild4
-rw-r--r--dev-python/bsddb3/files/bsddb3-4.1.3-setup.py.patch46
4 files changed, 60 insertions, 7 deletions
diff --git a/dev-python/bsddb3/ChangeLog b/dev-python/bsddb3/ChangeLog
index c0d87c89115c..03d7e6c08720 100644
--- a/dev-python/bsddb3/ChangeLog
+++ b/dev-python/bsddb3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/bsddb3
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.13 2004/06/26 21:22:04 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/ChangeLog,v 1.14 2004/09/26 12:05:16 liquidx Exp $
+
+ 26 Sep 2004; Alastair Tse <liquidx@gentoo.org>
+ +files/bsddb3-4.1.3-setup.py.patch, bsddb3-4.1.3.ebuild,
+ bsddb3-4.2.4.ebuild:
+ fix problems with 4.2 incompatibility with bsddb3-4.1.3 (#62017)
26 Jun 2004; Alastair Tse <liquidx@gentoo.org> bsddb3-4.1.3.ebuild:
fix bsddb3 to use the stable db4.1 (#51951)
diff --git a/dev-python/bsddb3/bsddb3-4.1.3.ebuild b/dev-python/bsddb3/bsddb3-4.1.3.ebuild
index b6bd28dddb6e..55f4593315c2 100644
--- a/dev-python/bsddb3/bsddb3-4.1.3.ebuild
+++ b/dev-python/bsddb3/bsddb3-4.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.1.3.ebuild,v 1.11 2004/06/26 21:22:04 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.1.3.ebuild,v 1.12 2004/09/26 12:05:16 liquidx Exp $
inherit distutils eutils
@@ -18,11 +18,13 @@ DEPEND="virtual/python
DOCS="README.txt TODO.txt"
-src_compile() {
- distutils_src_compile "--berkeley-db=/usr"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-setup.py.patch
}
src_install() {
- distutils_src_install "--berkeley-db=/usr"
+ distutils_src_install
dohtml docs/*
}
diff --git a/dev-python/bsddb3/bsddb3-4.2.4.ebuild b/dev-python/bsddb3/bsddb3-4.2.4.ebuild
index 930bea943a73..afd3edd9c8a9 100644
--- a/dev-python/bsddb3/bsddb3-4.2.4.ebuild
+++ b/dev-python/bsddb3/bsddb3-4.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.2.4.ebuild,v 1.5 2004/06/25 01:26:37 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.2.4.ebuild,v 1.6 2004/09/26 12:05:16 liquidx Exp $
inherit distutils eutils
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/pybsddb/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86" # ~ppc ~sparc"
+KEYWORDS="~ppc ~sparc ~x86"
IUSE=""
DEPEND="virtual/python
diff --git a/dev-python/bsddb3/files/bsddb3-4.1.3-setup.py.patch b/dev-python/bsddb3/files/bsddb3-4.1.3-setup.py.patch
new file mode 100644
index 000000000000..5a3fe0ed707a
--- /dev/null
+++ b/dev-python/bsddb3/files/bsddb3-4.1.3-setup.py.patch
@@ -0,0 +1,46 @@
+--- setup.py 2003-02-03 02:28:52.000000000 +0000
++++ /root/setup.py 2004-09-26 13:00:58.000000000 +0100
+@@ -46,37 +46,13 @@
+ # If we were not told where it is, go looking for it.
+ incdir = libdir = None
+ if not BERKELEYDB_DIR:
+- for dir in ('/usr/local', '/usr'):
+- for version in ('', '.4.1', '.4.0', '.3.3', '.3.2', '.3.1'):
+- instdir = os.path.join(dir, "BerkeleyDB"+version)
+- if os.path.exists(instdir):
+- BERKELEYDB_DIR = instdir
+- print "Found BerkeleyDB installation at " + instdir
++ for dir in ('/usr',):
++ for version in ('4.1', '4.0', '3.3', '3.2', '3.1'):
++ incdir = os.path.join(dir, "include/db" + version)
++ if os.path.exists(incdir):
++ libdir = os.path.join(dir, "lib")
++ libname = ['db-' + version]
+ break
+-
+- incdir = os.path.join(instdir, "include/db3")
+- if os.path.exists(incdir):
+- libdir = os.path.join(dir, "lib")
+- print "Found db3 header files at " + incdir
+- break
+- else:
+- incdir = None
+-
+-
+- if not BERKELEYDB_DIR and not incdir and not libdir:
+- print "Can't find a local BerkeleyDB installation."
+- print "(suggestion: try the --berkeley-db=/path/to/bsddb option)"
+- sys.exit(1)
+-
+- # figure out from the base setting where the lib and .h are
+- if not incdir:
+- incdir = os.path.join(BERKELEYDB_DIR, 'include')
+- if not libdir:
+- libdir = os.path.join(BERKELEYDB_DIR, 'lib')
+- if not '-ldb' in LIBS:
+- libname = ['db']
+- else:
+- libname = []
+ utils = []
+
+ # Test if the old bsddb is built-in