summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-02-22 16:55:27 +0000
committerAlex Brandt <alunduil@gentoo.org>2015-02-22 16:55:27 +0000
commit06b95ca70b4508585827dfb7e799a046bf0f8b8b (patch)
tree7059f0141738572dfa0242d6aff711ed9fa41a32 /dev-python/behave
parentVersion bump (diff)
downloadgentoo-2-06b95ca70b4508585827dfb7e799a046bf0f8b8b.tar.gz
gentoo-2-06b95ca70b4508585827dfb7e799a046bf0f8b8b.tar.bz2
gentoo-2-06b95ca70b4508585827dfb7e799a046bf0f8b8b.zip
add version 1.2.5
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 11A8217C!)
Diffstat (limited to 'dev-python/behave')
-rw-r--r--dev-python/behave/ChangeLog11
-rw-r--r--dev-python/behave/behave-1.2.5.ebuild53
2 files changed, 61 insertions, 3 deletions
diff --git a/dev-python/behave/ChangeLog b/dev-python/behave/ChangeLog
index 59c68775656d..c8cfc527c062 100644
--- a/dev-python/behave/ChangeLog
+++ b/dev-python/behave/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-python/behave
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/behave/ChangeLog,v 1.1 2014/10/22 01:12:16 alunduil Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/behave/ChangeLog,v 1.2 2015/02/22 16:55:27 alunduil Exp $
+
+*behave-1.2.5 (22 Feb 2015)
+
+ 22 Feb 2015; Alex Brandt <alunduil@gentoo.org> +behave-1.2.5.ebuild,
+ metadata.xml:
+ add version 1.2.5
*behave-1.2.4 (22 Oct 2014)
22 Oct 2014; Alex Brandt <alunduil@gentoo.org> +behave-1.2.4.ebuild,
+metadata.xml:
add ebuild written by me
-
diff --git a/dev-python/behave/behave-1.2.5.ebuild b/dev-python/behave/behave-1.2.5.ebuild
new file mode 100644
index 000000000000..50d3bcac7f81
--- /dev/null
+++ b/dev-python/behave/behave-1.2.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/behave/behave-1.2.5.ebuild,v 1.1 2015/02/22 16:55:27 alunduil Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="behaviour-driven development, Python style"
+HOMEPAGE="http://github.com/behave/behave"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
+ >=dev-python/sphinxcontrib-cheeseshop-0.2[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3[${PYTHON_USEDEP}]
+ >=dev-python/pyhamcrest-1.8[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/parse-1.6.3[${PYTHON_USEDEP}]
+ >=dev-python/parse-type-0.3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "nosetests failed under ${EPYTHON}"
+
+ ${PYTHON} -m behave --tags='~@xfail' features/ || die "behave features failed under ${EPYTHON}"
+ ${PYTHON} -m behave --tags='~@xfail' tools/test-features/ || die "behave test-festures failed under ${EPYTHON}"
+ ${PYTHON} -m behave --tags='~@xfail' issue.features/ || die "behave issue.features failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( build/docs/html/. )
+
+ distutils-r1_python_install_all
+}