summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-18 11:07:50 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-18 11:07:50 +0000
commitb92b26a061b624ea1047cf88ca5102a79528263d (patch)
treed84bcc0c900279c785951094b23d83eb6b1f18a8 /dev-python/beautifulsoup
parentx86 stable wrt bug #283362 (diff)
downloadgentoo-2-b92b26a061b624ea1047cf88ca5102a79528263d.tar.gz
gentoo-2-b92b26a061b624ea1047cf88ca5102a79528263d.tar.bz2
gentoo-2-b92b26a061b624ea1047cf88ca5102a79528263d.zip
Use PYTHON_DEPEND instead of NEED_PYTHON.
Diffstat (limited to 'dev-python/beautifulsoup')
-rw-r--r--dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r1.ebuild b/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r1.ebuild
index b8ddfc68a9e9..da1231cd0a9e 100644
--- a/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r1.ebuild
+++ b/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r1.ebuild,v 1.5 2010/05/22 16:15:36 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/beautifulsoup/beautifulsoup-3.1.0.1-r1.ebuild,v 1.6 2010/06/18 11:07:50 arfrever Exp $
-EAPI="2"
-NEED_PYTHON="3.0"
+EAPI="3"
+PYTHON_DEPEND="3"
SUPPORT_PYTHON_ABIS="1"
+# Avoid collisions with 3.0 slot.
+RESTRICT_PYTHON_ABIS="2.*"
inherit distutils eutils
@@ -12,7 +14,7 @@ MY_PN="BeautifulSoup"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="HTML/XML parser for quick-turnaround applications like screen-scraping."
-HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/"
+HOMEPAGE="http://www.crummy.com/software/BeautifulSoup/ http://pypi.python.org/pypi/BeautifulSoup"
SRC_URI="http://www.crummy.com/software/${MY_PN}/download/${MY_P}.tar.gz"
LICENSE="PSF-2.3"
@@ -23,8 +25,6 @@ IUSE=""
DEPEND=""
RDEPEND="!dev-python/beautifulsoup:0
dev-python/beautifulsoup:3.0"
-# Avoid collisions with 3.0 slot.
-RESTRICT_PYTHON_ABIS="2.*"
S="${WORKDIR}/${MY_P}"
@@ -46,5 +46,5 @@ src_install() {
distutils_src_install
# Delete useless files.
- rm -fr "${D%/}${EPREFIX}/usr/bin"
+ rm -fr "${ED}usr/bin"
}