summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-15 09:19:53 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-15 09:19:53 +0000
commit3090d1fc82b4371d6b1d80d8f99c825477e42a0d (patch)
treeb0fa0a9c9360c2e0925b56a57c47580281feb958 /dev-python/basemap
parentinitial import, ebuild by José Romildo Malaquias, bug #539326 (diff)
downloadgentoo-2-3090d1fc82b4371d6b1d80d8f99c825477e42a0d.tar.gz
gentoo-2-3090d1fc82b4371d6b1d80d8f99c825477e42a0d.tar.bz2
gentoo-2-3090d1fc82b4371d6b1d80d8f99c825477e42a0d.zip
revbump; convert -> distutils-r1, restrict test phase (see comments), rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/basemap')
-rw-r--r--dev-python/basemap/ChangeLog8
-rw-r--r--dev-python/basemap/basemap-1.0.7-r1.ebuild72
-rw-r--r--dev-python/basemap/basemap-1.0.7.ebuild76
3 files changed, 79 insertions, 77 deletions
diff --git a/dev-python/basemap/ChangeLog b/dev-python/basemap/ChangeLog
index acc001f052f3..44f2298d772e 100644
--- a/dev-python/basemap/ChangeLog
+++ b/dev-python/basemap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/basemap
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/basemap/ChangeLog,v 1.34 2015/02/02 14:48:08 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/basemap/ChangeLog,v 1.35 2015/02/15 09:19:53 idella4 Exp $
+
+*basemap-1.0.7-r1 (15 Feb 2015)
+
+ 15 Feb 2015; Ian Delaney <idella4@gentoo.org> +basemap-1.0.7-r1.ebuild,
+ -basemap-1.0.7.ebuild:
+ revbump; convert -> distutils-r1, restrict test phase (see comments), rm old
02 Feb 2015; Manuel Rüger <mrueg@gentoo.org> -basemap-1.0.6.ebuild:
Remove old.
diff --git a/dev-python/basemap/basemap-1.0.7-r1.ebuild b/dev-python/basemap/basemap-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..db3025040c92
--- /dev/null
+++ b/dev-python/basemap/basemap-1.0.7-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/basemap/basemap-1.0.7-r1.ebuild,v 1.1 2015/02/15 09:19:53 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="matplotlib toolkit to plot map projections"
+HOMEPAGE="http://matplotlib.sourceforge.net/basemap/doc/html/ http://pypi.python.org/pypi/basemap"
+SRC_URI="mirror://sourceforge/matplotlib/${P}.tar.gz"
+
+IUSE="examples test"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="MIT GPL-2"
+
+CDEPEND="sci-libs/shapelib
+ >=dev-python/matplotlib-0.98[${PYTHON_USEDEP}]
+ >=sci-libs/geos-3.3.1[python,${PYTHON_USEDEP}]"
+
+DEPEND="${CDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${CDEPEND}
+ >=dev-python/pupynere-1.0.8[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/dap[${PYTHON_USEDEP}]"
+
+DOCS="FAQ API_CHANGES"
+#REQUIRED_USE="test? ( examples )"
+# The test phase ought never have been onvoked according to the above.
+# The test phase appears to require the package to fist be emerged, which ...
+# Until the distutils_install_for_testing func refrains from failing with
+# mkdir: cannot create directory ‘/test’: Permission denied
+# reluctantly this phase is assigned
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e "s:/usr:${EPREFIX}/usr:g" \
+ setup.py || die
+ # use /usr/share/data
+ sed -i \
+ -e "/_datadir.*=.*join/s|\(.*datadir.*=\).*|\1'${EROOT}usr/share/${PN}'|g" \
+ "${S}"/lib/mpl_toolkits/basemap/*.py || die
+ distutils-r1_src_prepare
+}
+
+#src_test() {
+# distutils_install_for_testing
+#}
+
+python_install() {
+ distutils-r1_python_install
+ # --install-data="${EPREFIX}/usr/share/${PN}" on testing is found not to work;
+ # setup.py is a mess. Someone care to patch setup.py please proceed; substitute with
+ insinto usr/share/basemap/
+ doins lib/mpl_toolkits/basemap/data/*
+
+ # clean up collision with matplotlib
+ rm -f "${D}$(python_get_sitedir)/mpl_toolkits/__init__.py"
+ # respect FHS
+ rm -fr "${D}$(python_get_sitedir)/mpl_toolkits/basemap/data"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/basemap/basemap-1.0.7.ebuild b/dev-python/basemap/basemap-1.0.7.ebuild
deleted file mode 100644
index 71fc5c87d007..000000000000
--- a/dev-python/basemap/basemap-1.0.7.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/basemap/basemap-1.0.7.ebuild,v 1.1 2013/08/26 04:55:43 patrick Exp $
-
-EAPI=4
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
-
-inherit eutils distutils virtualx
-
-DESCRIPTION="matplotlib toolkit to plot map projections"
-HOMEPAGE="http://matplotlib.sourceforge.net/basemap/doc/html/ http://pypi.python.org/pypi/basemap"
-SRC_URI="mirror://sourceforge/matplotlib/${P}.tar.gz"
-
-IUSE="examples test"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-LICENSE="MIT GPL-2"
-
-CDEPEND="sci-libs/shapelib
- >=dev-python/matplotlib-0.98
- >=sci-libs/geos-3.3.1[python]"
-
-DEPEND="${CDEPEND}
- dev-python/setuptools"
-
-RDEPEND="${CDEPEND}
- >=dev-python/pupynere-1.0.8
- dev-python/httplib2
- dev-python/dap"
-
-DOCS="FAQ API_CHANGES"
-
-REQUIRED_USE="test? ( examples )"
-
-src_prepare() {
- sed -i \
- -e "s:/usr:${EPREFIX}/usr:g" \
- setup.py || die
- # use /usr/share/data
- sed -i \
- -e "/_datadir.*=.*join/s|\(.*datadir.*=\).*|\1'${EROOT}usr/share/${PN}'|g" \
- "${S}"/lib/mpl_toolkits/basemap/*.py || die
- distutils_src_prepare
-}
-
-# This one works. examples appear to be need be installed to run.
-src_test() {
- testing() {
- pushd "$(find build-${PYTHON_ABI} -name lib.\*)/mpl_toolkits/basemap/"
- PYTHONPATH=.:../../ "$(PYTHON)" test.py
- popd
- }
- VIRTUALX_COMMAND=python_execute_function virtualmake testing
-}
-
-src_install() {
- distutils_src_install --install-data="${EPREFIX}/usr/share/${PN}"
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-
- # respect FHS
- mv "${ED}$(python_get_sitedir -f)/mpl_toolkits/basemap/data" "${ED}usr/share/basemap"
-
- cleaning() {
- # clean up collision with matplotlib
- rm -f "${ED}$(python_get_sitedir)/mpl_toolkits/__init__.py"
- # respect FHS
- rm -fr "${ED}$(python_get_sitedir)/mpl_toolkits/basemap/data"
- }
- python_execute_function -q cleaning
-}