summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-03-12 00:47:14 +0000
committerIan Delaney <idella4@gentoo.org>2015-03-12 00:47:14 +0000
commit7f668a4552eb4a0c39088d2b5cf692767d4eeb01 (patch)
tree0396c380ee2335d46264d1c6e57d35155b9741ef /dev-python/autopep8
parentbump version (diff)
downloadgentoo-2-7f668a4552eb4a0c39088d2b5cf692767d4eeb01.tar.gz
gentoo-2-7f668a4552eb4a0c39088d2b5cf692767d4eeb01.tar.bz2
gentoo-2-7f668a4552eb4a0c39088d2b5cf692767d4eeb01.zip
re-add dep setuptools to RDEPEND, noted by Arfrever, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/ChangeLog7
-rw-r--r--dev-python/autopep8/autopep8-0.9.5.ebuild35
-rw-r--r--dev-python/autopep8/autopep8-1.0.1.ebuild41
-rw-r--r--dev-python/autopep8/autopep8-1.1.1.ebuild11
-rw-r--r--dev-python/autopep8/autopep8-1.1.ebuild13
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild13
6 files changed, 26 insertions, 94 deletions
diff --git a/dev-python/autopep8/ChangeLog b/dev-python/autopep8/ChangeLog
index 8eaa0c0c51e9..19e921e22a2e 100644
--- a/dev-python/autopep8/ChangeLog
+++ b/dev-python/autopep8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/autopep8
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.56 2015/03/08 23:39:55 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/ChangeLog,v 1.57 2015/03/12 00:47:14 idella4 Exp $
+
+ 12 Mar 2015; Ian Delaney <idella4@gentoo.org> -autopep8-0.9.5.ebuild,
+ -autopep8-1.0.1.ebuild, autopep8-1.1.1.ebuild, autopep8-1.1.ebuild,
+ autopep8-9999.ebuild:
+ re-add dep setuptools to RDEPEND, noted by Arfrever, rm old
08 Mar 2015; Pacho Ramos <pacho@gentoo.org> autopep8-1.0.4.ebuild:
x86 stable, bug 540290
diff --git a/dev-python/autopep8/autopep8-0.9.5.ebuild b/dev-python/autopep8/autopep8-0.9.5.ebuild
deleted file mode 100644
index 74fc2560ba25..000000000000
--- a/dev-python/autopep8/autopep8-0.9.5.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-0.9.5.ebuild,v 1.3 2013/11/24 13:49:06 ago Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
-SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND=">=dev-python/pep8-1.4.6[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_test() {
- "${PYTHON}" setup.py test || die
-}
-
-pkg_postinst() {
- ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
- ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
- ewarn "(indentation checks inside triple-quotes)."
- ewarn "If you do not want to be affected by this, then add the"
- ewarn "following lines to your local package.mask:"
- ewarn " >=dev-python/pep8-1.3"
- ewarn " >=dev-python/autopep8-0.6"
-}
diff --git a/dev-python/autopep8/autopep8-1.0.1.ebuild b/dev-python/autopep8/autopep8-1.0.1.ebuild
deleted file mode 100644
index 0af7aecaa935..000000000000
--- a/dev-python/autopep8/autopep8-1.0.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-1.0.1.ebuild,v 1.4 2014/06/08 03:06:43 floppym Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
-HOMEPAGE="https://github.com/hhatto/autopep8 http://pypi.python.org/pypi/autopep8"
-SRC_URI="https://github.com/hhatto/${PN}/tarball/ver${PV} -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND=">=dev-python/pep8-1.5.6[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_prepare_all() {
- # Prevent UnicodeDecodeError with LANG=C
- sed -e "/é/d" -i MANIFEST.in || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
-
-pkg_postinst() {
- ewarn "Since this version of autopep depends on >=dev-python/pep8-1.3"
- ewarn "it is affected by https://github.com/jcrocholl/pep8/issues/45"
- ewarn "(indentation checks inside triple-quotes)."
- ewarn "If you do not want to be affected by this, then add the"
- ewarn "following lines to your local package.mask:"
- ewarn " >=dev-python/pep8-1.3"
- ewarn " >=dev-python/autopep8-0.6"
-}
diff --git a/dev-python/autopep8/autopep8-1.1.1.ebuild b/dev-python/autopep8/autopep8-1.1.1.ebuild
index 3e58c7e06bb4..9af59de768f2 100644
--- a/dev-python/autopep8/autopep8-1.1.1.ebuild
+++ b/dev-python/autopep8/autopep8-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-1.1.1.ebuild,v 1.1 2015/02/28 07:10:07 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-1.1.1.ebuild,v 1.2 2015/03/12 00:47:14 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
@@ -16,10 +16,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
-RDEPEND=">=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
python_prepare_all() {
# Prevent UnicodeDecodeError with LANG=C
diff --git a/dev-python/autopep8/autopep8-1.1.ebuild b/dev-python/autopep8/autopep8-1.1.ebuild
index cbf4e4533f4e..a07fa7cb1076 100644
--- a/dev-python/autopep8/autopep8-1.1.ebuild
+++ b/dev-python/autopep8/autopep8-1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-1.1.ebuild,v 1.1 2014/12/23 07:01:50 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-1.1.ebuild,v 1.2 2015/03/12 00:47:14 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
@@ -16,10 +16,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
-RDEPEND=">=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
python_prepare_all() {
# Prevent UnicodeDecodeError with LANG=C
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index da7d0b6cb597..f3e042869a1d 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-9999.ebuild,v 1.10 2014/12/23 07:01:50 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/autopep8/autopep8-9999.ebuild,v 1.11 2015/03/12 00:47:14 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
@@ -17,10 +17,11 @@ SLOT="0"
KEYWORDS=""
IUSE="test"
-RDEPEND=">=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? ( >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}] )"
python_test() {
"${PYTHON}" setup.py test || die