summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-01-19 20:46:21 +0000
committerMichał Górny <mgorny@gentoo.org>2013-01-19 20:46:21 +0000
commit929963e1779fc78d58fa2df020762da267492ad6 (patch)
tree4b1f722091c9f0b3655618c60b060e416cc3b143 /dev-python/apipkg
parent[bump] dev-perl/Net-SSLeay-1.520.0 (diff)
downloadgentoo-2-929963e1779fc78d58fa2df020762da267492ad6.tar.gz
gentoo-2-929963e1779fc78d58fa2df020762da267492ad6.tar.bz2
gentoo-2-929963e1779fc78d58fa2df020762da267492ad6.zip
Migrate to distutils-r1.
(Portage version: 2.2.0_alpha155/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/apipkg')
-rw-r--r--dev-python/apipkg/ChangeLog10
-rw-r--r--dev-python/apipkg/apipkg-1.2-r1.ebuild25
2 files changed, 32 insertions, 3 deletions
diff --git a/dev-python/apipkg/ChangeLog b/dev-python/apipkg/ChangeLog
index 2085eb9977b2..e2fe462d9bb8 100644
--- a/dev-python/apipkg/ChangeLog
+++ b/dev-python/apipkg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/apipkg
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/apipkg/ChangeLog,v 1.4 2012/06/19 17:44:19 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apipkg/ChangeLog,v 1.5 2013/01/19 20:46:21 mgorny Exp $
+
+*apipkg-1.2-r1 (19 Jan 2013)
+
+ 19 Jan 2013; Michał Górny <mgorny@gentoo.org> +apipkg-1.2-r1.ebuild:
+ Migrate to distutils-r1.
19 Jun 2012; Kacper Kowalik <xarthisius@gentoo.org> apipkg-1.2.ebuild:
Drop MY_P, bump to eapi4, add missing dependency on app-arch/unzip, drop test
@@ -22,4 +27,3 @@
02 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+apipkg-1.0_beta6.ebuild, +metadata.xml:
Initial addition. Ebuild written by me.
-
diff --git a/dev-python/apipkg/apipkg-1.2-r1.ebuild b/dev-python/apipkg/apipkg-1.2-r1.ebuild
new file mode 100644
index 000000000000..f68191096b13
--- /dev/null
+++ b/dev-python/apipkg/apipkg-1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/apipkg/apipkg-1.2-r1.ebuild,v 1.1 2013/01/19 20:46:21 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="namespace control and lazy-import mechanism"
+HOMEPAGE="http://pypi.python.org/pypi/apipkg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}