summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-07-16 14:35:36 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-07-16 14:35:36 +0000
commit2dcf766959f4a146b05b858d95ff8ec9dfa2ab69 (patch)
treee5d06e9df571343309ecad2d4451c0c209d91e1e /dev-python/adodb-py/adodb-py-2.01.ebuild
parentversion bump. thanks to Manuzhai (#129987) (diff)
downloadgentoo-2-2dcf766959f4a146b05b858d95ff8ec9dfa2ab69.tar.gz
gentoo-2-2dcf766959f4a146b05b858d95ff8ec9dfa2ab69.tar.bz2
gentoo-2-2dcf766959f4a146b05b858d95ff8ec9dfa2ab69.zip
version bump (#137155). cleanup old ebuilds
(Portage version: 2.1-r1)
Diffstat (limited to 'dev-python/adodb-py/adodb-py-2.01.ebuild')
-rw-r--r--dev-python/adodb-py/adodb-py-2.01.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/adodb-py/adodb-py-2.01.ebuild b/dev-python/adodb-py/adodb-py-2.01.ebuild
new file mode 100644
index 000000000000..faeed7b235bc
--- /dev/null
+++ b/dev-python/adodb-py/adodb-py-2.01.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/adodb-py/adodb-py-2.01.ebuild,v 1.1 2006/07/16 14:35:36 liquidx Exp $
+
+inherit distutils
+
+MY_P=${PN}${PV//./}
+
+DESCRIPTION="Active Data Objects Data Base library for Python"
+HOMEPAGE="http://adodb.sourceforge.net/"
+SRC_URI="mirror://sourceforge/adodb/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ia64 ~ppc ~x86"
+IUSE="mysql postgres sqlite"
+
+RDEPEND=">=dev-lang/python-2.3
+ postgres? ( >=dev-python/psycopg-1.1.5.1 )
+ mysql? ( >=dev-python/mysql-python-0.9.2 )
+ sqlite? ( >=dev-python/pysqlite-2.0 ) "
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P/py/}"
+
+DOCS="LICENSE.txt README.txt"
+
+src_install() {
+ distutils_src_install
+ dohtml adodb-py-docs.htm icons/*.gif
+}