summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-04-02 13:24:15 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-04-02 13:24:15 +0000
commit0612f62e378805c5f10f6500461cf1af8d4269fd (patch)
tree3d60627beb2f2a9d6872725a9cdd2fb3059e35e2 /dev-python/PyQt
parentFixed sandbox violations and dependency clean ups (diff)
downloadgentoo-2-0612f62e378805c5f10f6500461cf1af8d4269fd.tar.gz
gentoo-2-0612f62e378805c5f10f6500461cf1af8d4269fd.tar.bz2
gentoo-2-0612f62e378805c5f10f6500461cf1af8d4269fd.zip
updated version, removed old one
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/PyQt-3.0.ebuild49
-rw-r--r--dev-python/PyQt/PyQt-3.1.ebuild45
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.05
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.11
4 files changed, 46 insertions, 54 deletions
diff --git a/dev-python/PyQt/PyQt-3.0.ebuild b/dev-python/PyQt/PyQt-3.0.ebuild
deleted file mode 100644
index 110b8f303adc..000000000000
--- a/dev-python/PyQt/PyQt-3.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.0.ebuild,v 1.4 2002/02/17 18:56:03 karltk Exp $
-
-S="${WORKDIR}/PyQt-3.0"
-DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit( VERSION 3.x ONLY!!."
-SRC_URI="http://www.river-bank.demon.co.uk/software/PyQt-3.0-Qt-3.0.0.tar.gz
- http://www.river-bank.demon.co.uk/software/PyQt-3.0-Qt-3.0.0-patch.1
- http://www.river-bank.demon.co.uk/software/PyQt-3.0-Qt-3.0.0-patch.2
- http://www.river-bank.demon.co.uk/software/PyQt-3.0-Qt-3.0.0-patch.3
- http://www.river-bank.demon.co.uk/software/PyQt-3.0-Qt-3.0.0-patch.4
- "
-HOMEPAGE="http://www.thekompany.com/projects/pykde/"
-
-DEPEND="virtual/glibc
- =x11-libs/qt-3*
- =dev-python/sip-3.0
- >=dev-lang/python-2.0"
-
-src_unpack() {
-
- unpack PyQt-3.0-Qt-3.0.0.tar.gz
- cd ${WORKDIR}
- patch -p0 < ${DISTDIR}/PyQt-3.0-Qt-3.0.0-patch.1 || die
- patch -p0 < ${DISTDIR}/PyQt-3.0-Qt-3.0.0-patch.2 || die
- patch -p0 < ${DISTDIR}/PyQt-3.0-Qt-3.0.0-patch.3 || die
- patch -p0 < ${DISTDIR}/PyQt-3.0-Qt-3.0.0-patch.4 || die
- cd ${S}
-
-}
-
-src_compile() {
- ./configure --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-doc-install=/usr/share/doc \
- --with-qt-dir=/usr/qt/3 \
- --with-qt-includes=/usr/qt/3/include \
- --with-qt-libraries=/usr/qt/3/lib \
- --with-x || die
-
- make || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- make DESTDIR=${D} install-doc || die
-}
diff --git a/dev-python/PyQt/PyQt-3.1.ebuild b/dev-python/PyQt/PyQt-3.1.ebuild
new file mode 100644
index 000000000000..82ae7788371f
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.1.ebuild,v 1.1 2002/04/02 13:23:51 verwilst Exp $
+
+
+S="${WORKDIR}/PyQt-3.1"
+DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit( VERSION 3.x ONLY!!)."
+SRC_URI="http://www.riverbankcomputing.co.uk/download/PyQt/PyQt-3.1-Qt-3.0.2.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ sys-devel/libtool
+ >=x11-libs/qt-3.0.2
+ >=dev-lang/python-2.2
+ =dev-python/sip-3.1"
+
+src_compile() {
+
+ # Fix for one installation problem. The libtool included with the
+ # source package does not have the relink patch.
+ # Use the system libtool instead.
+ cd ${S}
+ cp /usr/bin/libtool .
+ cp /usr/share/libtool/ltmain.sh .
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-doc-install=/usr/share/doc \
+ --with-qt-dir=/usr/qt/3 \
+ --with-qt-includes=/usr/qt/3/include \
+ --with-qt-libraries=/usr/qt/3/lib \
+ --with-x || die
+
+ make || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+ make DESTDIR=${D} install-doc || die
+
+}
+
diff --git a/dev-python/PyQt/files/digest-PyQt-3.0 b/dev-python/PyQt/files/digest-PyQt-3.0
deleted file mode 100644
index 9a35445d149f..000000000000
--- a/dev-python/PyQt/files/digest-PyQt-3.0
+++ /dev/null
@@ -1,5 +0,0 @@
-MD5 5e227ea0b0ad132f9eafa55fb7f90ea8 PyQt-3.0-Qt-3.0.0.tar.gz 2372458
-MD5 146bb111ea6bec8f16d14d1026b77759 PyQt-3.0-Qt-3.0.0-patch.1 1931
-MD5 8be7eac9204474a85aaa15de32df52c2 PyQt-3.0-Qt-3.0.0-patch.2 1819
-MD5 e243da5f0d0f1a5c299ce66aae079b65 PyQt-3.0-Qt-3.0.0-patch.3 5722
-MD5 ddcfe9c7cf957047faa93bdb08e3f0e4 PyQt-3.0-Qt-3.0.0-patch.4 1420
diff --git a/dev-python/PyQt/files/digest-PyQt-3.1 b/dev-python/PyQt/files/digest-PyQt-3.1
new file mode 100644
index 000000000000..643e5e72b4b1
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.1
@@ -0,0 +1 @@
+MD5 460c5be0afbd3573e7cea3de8995ec90 PyQt-3.1-Qt-3.0.2.tar.gz 2598298