summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-12-26 00:56:22 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-12-26 00:56:22 +0000
commit80476db1ed595033ef94206d058ad9b41f049f21 (patch)
treebbf9044adaefd220af0a56e23a80cf7236c34b6f /dev-python/PyQt4
parentBumping commons-digester (diff)
downloadgentoo-2-80476db1ed595033ef94206d058ad9b41f049f21.tar.gz
gentoo-2-80476db1ed595033ef94206d058ad9b41f049f21.tar.bz2
gentoo-2-80476db1ed595033ef94206d058ad9b41f049f21.zip
version bump
(Portage version: 2.1.4_rc11)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog7
-rw-r--r--dev-python/PyQt4/PyQt4-4.3.3.ebuild53
-rw-r--r--dev-python/PyQt4/files/digest-PyQt4-4.3.33
3 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 434776c2de32..940c8be87510 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.20 2007/11/28 12:56:37 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.21 2007/12/26 00:56:22 caleb Exp $
+
+*PyQt4-4.3.3 (26 Dec 2007)
+
+ 26 Dec 2007; Caleb Tennis <caleb@gentoo.org> +PyQt4-4.3.3.ebuild:
+ version bump
28 Nov 2007; Caleb Tennis <caleb@gentoo.org> -PyQt4-4.2.ebuild,
-PyQt4-4.3.ebuild:
diff --git a/dev-python/PyQt4/PyQt4-4.3.3.ebuild b/dev-python/PyQt4/PyQt4-4.3.3.ebuild
new file mode 100644
index 000000000000..18b686846c8f
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.3.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.3.3.ebuild,v 1.1 2007/12/26 00:56:22 caleb Exp $
+
+inherit distutils qt4
+
+MY_P=PyQt-x11-gpl-${PV}
+
+DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt4/GPL/${MY_P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc examples"
+
+RDEPEND="=x11-libs/qt-4*
+ >=dev-python/sip-4.7.3"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+S=${WORKDIR}/${MY_P}
+
+QT4_BUILT_WITH_USE_CHECK="zlib"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s:^[ \t]*check_license():# check_license():" "${S}"/configure.py
+ sed -i -e "s:join(qt_dir, \"mkspecs\":join(\"/usr/share/qt4\", \"mkspecs\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include\":\"QT_INSTALL_HEADERS\"\: os.path.join(qt_dir, \"include/qt4\":g" "${S}"/configure.py
+ sed -i -e "s:\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib\":\"QT_INSTALL_LIBS\"\: os.path.join(qt_dir, \"lib/qt4\":g" "${S}"/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages -b /usr/bin -v /usr/share/sip"
+ use debug && myconf="${myconf} -u"
+
+ "${python}" configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml -r doc/html/*
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
diff --git a/dev-python/PyQt4/files/digest-PyQt4-4.3.3 b/dev-python/PyQt4/files/digest-PyQt4-4.3.3
new file mode 100644
index 000000000000..d19802957b9b
--- /dev/null
+++ b/dev-python/PyQt4/files/digest-PyQt4-4.3.3
@@ -0,0 +1,3 @@
+MD5 a2ead359f57d84c24bdd10de387e80b4 PyQt-x11-gpl-4.3.3.tar.gz 6191266
+RMD160 8d25e15d8529b6a0f08b112f00a85a4b87b5ff88 PyQt-x11-gpl-4.3.3.tar.gz 6191266
+SHA256 d36383e40a983f4d5d53b38bb85409e55a82e3aac0d7296abe68d913befa1e55 PyQt-x11-gpl-4.3.3.tar.gz 6191266