summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-08-16 13:46:10 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-08-16 13:46:10 +0000
commit7c83dcc9f590b0807d78b9aa1e4ca26890431a5a (patch)
treea2a5c4e43729b3a1ec2e9ddff925fc3a7f37128e /dev-python/PyQt4
parentstable amd64, bug 280125 (diff)
downloadgentoo-2-7c83dcc9f590b0807d78b9aa1e4ca26890431a5a.tar.gz
gentoo-2-7c83dcc9f590b0807d78b9aa1e4ca26890431a5a.tar.bz2
gentoo-2-7c83dcc9f590b0807d78b9aa1e4ca26890431a5a.zip
Remove old ebuilds
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog6
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.4-r2.ebuild152
-rw-r--r--dev-python/PyQt4/PyQt4-4.5.4.ebuild138
3 files changed, 5 insertions, 291 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 971d617d0411..e191dcdb12f7 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.84 2009/08/16 13:30:42 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.85 2009/08/16 13:46:10 hwoarang Exp $
+
+ 16 Aug 2009; Markos Chandras <hwoarang@gentoo.org> -PyQt4-4.5.4.ebuild,
+ -PyQt4-4.5.4-r2.ebuild:
+ Remove old ebuilds
16 Aug 2009; Thomas Anderson <gentoofan23@gentoo.org>
PyQt4-4.4.4-r5.ebuild:
diff --git a/dev-python/PyQt4/PyQt4-4.5.4-r2.ebuild b/dev-python/PyQt4/PyQt4-4.5.4-r2.ebuild
deleted file mode 100644
index 90cf37472918..000000000000
--- a/dev-python/PyQt4/PyQt4-4.5.4-r2.ebuild
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4-r2.ebuild,v 1.1 2009/08/11 08:44:38 hwoarang Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python qt4 toolchain-funcs
-
-MY_P=PyQt-x11-gpl-${PV}
-QTVER="4.5.1"
-
-DESCRIPTION="A set of Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 GPL-3 )"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
-
-DEPEND=">=dev-python/sip-4.8.2
- >=x11-libs/qt-core-${QTVER}:4
- >=x11-libs/qt-script-${QTVER}:4
- >=x11-libs/qt-test-${QTVER}:4
- X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
- assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
- dbus? (
- >=dev-python/dbus-python-0.80
- >=x11-libs/qt-dbus-${QTVER}:4
- )
- opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
- phonon? (
- !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
- kde? ( media-sound/phonon )
- )
- sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
- svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
- webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
- xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/configure.py.patch"
-)
-
-src_prepare() {
- if ! use dbus; then
- sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
- "${S}"/configure.py || die
- fi
- qt4_src_prepare
-
- python_copy_sources
-
- preparation() {
- if [[ "${PYTHON_ABI:0:1}" == "3" ]]; then
- rm -fr pyuic/uic/port_v2
- else
- rm -fr pyuic/uic/port_v3
- fi
- }
- python_execute_function -s preparation
-}
-
-pyqt4_use_enable() {
- use $1 && echo "--enable=${2:-$1}"
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --confirm-license
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtScript
- --enable=QtTest
- --enable=QtXml
- $(pyqt4_use_enable X QtGui)
- $(pyqt4_use_enable X QtDesigner)
- $(pyqt4_use_enable assistant QtAssistant)
- $(pyqt4_use_enable assistant QtHelp)
- $(pyqt4_use_enable opengl QtOpenGL)
- $(pyqt4_use_enable phonon)
- $(pyqt4_use_enable sql QtSql)
- $(pyqt4_use_enable svg QtSvg)
- $(pyqt4_use_enable webkit QtWebKit)
- $(pyqt4_use_enable xmlpatterns QtXmlPatterns)
- CC=$(tc-getCC) CXX=$(tc-getCXX)
- LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
- CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}' LFLAGS='${LDFLAGS}'"
- echo ${myconf}
- eval ${myconf} || return 1
-
- # Fix insecure runpath.
- for mod in QtCore $(use X && echo 'QtDesigner QtGui'); do
- # Run eqmake4 to inside the qpy subdirs to prevent
- # stripping and many QA issues
- pushd qpy/${mod} > /dev/null || die
- eqmake4 $(ls w_qpy*.pro)
- popd > /dev/null || die
- sed -i -e "/^LFLAGS/s:-Wl,-rpath,${BUILDDIR}/qpy/${mod}::" ${mod}/Makefile || die "Failed to fix rpath issues"
- done
-
- # Fix pre-stripping of libpythonplugin.so
- if use X; then
- cd "${BUILDDIR}"/designer
- eqmake4 python.pro
- fi
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_execute_function -d -s
-}
-
-src_install() {
- python_need_rebuild
-
- installation() {
- # INSTALL_ROOT is needed for the QtDesigner module,
- # the other Makefiles use DESTDIR.
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
- }
- python_execute_function -s installation
-
- dodoc ChangeLog doc/pyqt4ref.txt NEWS THANKS || die
-
- if use doc; then
- dohtml -r doc/* || die
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize PyQt4
-}
-
-pkg_postrm() {
- python_mod_cleanup PyQt4
-}
diff --git a/dev-python/PyQt4/PyQt4-4.5.4.ebuild b/dev-python/PyQt4/PyQt4-4.5.4.ebuild
deleted file mode 100644
index cd42dc336484..000000000000
--- a/dev-python/PyQt4/PyQt4-4.5.4.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.5.4.ebuild,v 1.7 2009/08/05 18:45:33 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit python qt4
-
-MY_P=PyQt-x11-gpl-${PV}
-QTVER="4.5.1"
-
-DESCRIPTION="A set of Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="|| ( GPL-2 GPL-3 )"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
-
-DEPEND=">=dev-python/sip-4.8.2
- >=x11-libs/qt-core-${QTVER}:4
- >=x11-libs/qt-script-${QTVER}:4
- >=x11-libs/qt-test-${QTVER}:4
- X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
- assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
- dbus? (
- >=dev-python/dbus-python-0.80
- >=x11-libs/qt-dbus-${QTVER}:4
- )
- opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
- phonon? (
- !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
- kde? ( media-sound/phonon )
- )
- sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
- svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
- webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
- xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/configure.py.patch"
-)
-
-pyqt4_use_enable() {
- use $1 && echo "--enable=${2:-$1}"
-}
-
-src_prepare() {
- if ! use dbus; then
- sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
- "${S}"/configure.py || die
- fi
- qt4_src_prepare
-
- python_copy_sources
-
- preparation() {
- if [[ "${PYTHON_ABI:0:1}" == "3" ]]; then
- rm -fr pyuic/uic/port_v2
- else
- rm -fr pyuic/uic/port_v3
- fi
- }
- python_execute_function -s preparation
-}
-
-src_configure() {
- configuration() {
- local myconf="$(PYTHON) configure.py
- --confirm-license
- --bindir=/usr/bin
- --destdir=$(python_get_sitedir)
- --sipdir=/usr/share/sip
- $(use debug && echo '--debug')
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtScript
- --enable=QtTest
- --enable=QtXml
- $(pyqt4_use_enable X QtGui)
- $(pyqt4_use_enable X QtDesigner)
- $(pyqt4_use_enable assistant QtAssistant)
- $(pyqt4_use_enable assistant QtHelp)
- $(pyqt4_use_enable opengl QtOpenGL)
- $(pyqt4_use_enable phonon)
- $(pyqt4_use_enable sql QtSql)
- $(pyqt4_use_enable svg QtSvg)
- $(pyqt4_use_enable webkit QtWebKit)
- $(pyqt4_use_enable xmlpatterns QtXmlPatterns)"
- echo ${myconf}
- ${myconf} || return 1
-
- # Fix insecure runpath.
- for pkg in QtCore $(use X && echo "QtDesigner QtGui"); do
- sed -i -e "/^LFLAGS/s:-Wl,-rpath,${BUILDDIR}/qpy/${pkg}::" ${pkg}/Makefile || die "Failed to fix rpath issues"
- done
- }
- python_execute_function -s configuration
-}
-
-src_compile() {
- python_execute_function -d -s
-}
-
-src_install() {
- python_need_rebuild
-
- installation() {
- # INSTALL_ROOT is needed for the QtDesigner module,
- # the other Makefiles use DESTDIR.
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
- }
- python_execute_function -s installation
-
- dodoc ChangeLog NEWS THANKS || die
-
- if use doc; then
- dohtml -r doc/* || die
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize PyQt4
-}
-
-pkg_postrm() {
- python_mod_cleanup PyQt4
-}