summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-08 01:15:10 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-08 01:15:10 +0000
commit5e854edc4b2ba54e175a35ff1198df6a6a31b00a (patch)
tree0389f96c9a976463a5efc83a3904c9344f50ff61 /dev-python/Coffin
parentLinux patch 3.14.6. Removal of redundant patches (diff)
downloadgentoo-2-5e854edc4b2ba54e175a35ff1198df6a6a31b00a.tar.gz
gentoo-2-5e854edc4b2ba54e175a35ff1198df6a6a31b00a.tar.bz2
gentoo-2-5e854edc4b2ba54e175a35ff1198df6a6a31b00a.zip
new dep to testsuite of django-compressor
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/Coffin')
-rw-r--r--dev-python/Coffin/ChangeLog9
-rw-r--r--dev-python/Coffin/Coffin-0.3.8.ebuild27
-rw-r--r--dev-python/Coffin/Manifest3
-rw-r--r--dev-python/Coffin/metadata.xml5
4 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/Coffin/ChangeLog b/dev-python/Coffin/ChangeLog
new file mode 100644
index 000000000000..45bfe4442fba
--- /dev/null
+++ b/dev-python/Coffin/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-python/Coffin
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Coffin/ChangeLog,v 1.1 2014/06/08 01:15:10 idella4 Exp $
+
+*Coffin-0.3.8 (08 Jun 2014)
+
+ 08 Jun 2014; Ian Delaney <idella4@gentoo.org> +Coffin-0.3.8.ebuild,
+ +metadata.xml:
+ new dep to testsuite of django-compressor
diff --git a/dev-python/Coffin/Coffin-0.3.8.ebuild b/dev-python/Coffin/Coffin-0.3.8.ebuild
new file mode 100644
index 000000000000..3b59b3d630de
--- /dev/null
+++ b/dev-python/Coffin/Coffin-0.3.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Coffin/Coffin-0.3.8.ebuild,v 1.1 2014/06/08 01:15:10 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Jinja2 adapter for Django"
+HOMEPAGE="http://github.com/coffin/coffin"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_prepare_all() {
+ # Req'd to avoid file collisions
+ sed -e s":find_packages():find_packages(exclude=['tests']):" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/Coffin/Manifest b/dev-python/Coffin/Manifest
new file mode 100644
index 000000000000..f779a937938c
--- /dev/null
+++ b/dev-python/Coffin/Manifest
@@ -0,0 +1,3 @@
+DIST Coffin-0.3.8.tar.gz 35269 SHA256 be3e804ea1c740d8f09c0f811253eee4c6aeeb993455521cac6e95e1e4d6151b SHA512 e3e0b9855e14b7fc57cd164aa3ba50f84847eb8a324d4ceaf52513224d235889407c061d542a894b82d6cdc96fc378fd44856d46f471333017d7a6ac6427c7d3 WHIRLPOOL c8105e5900e0f07a461689ca0c7295bb483991ec86466f4e72b8e837631fe6135a5db9192598d1f763bbfff773a06d5b611e391620a9ac76f3313f475802d978
+EBUILD Coffin-0.3.8.ebuild 620 SHA256 1b740ae6415ae234feaf04cb88118fa8c03ed9e54917b23f57b2a40e4cd17a91 SHA512 f706d3e15e3c394d7786878d8b7636056968c551b15a0c80b274abf2d2e18c3ac728f680065d5cc071edef7bc068b13b3df2552d19e3d81f4016b40321e4daa1 WHIRLPOOL a65cdf54fbab04305b3a5e32d95000de664aa97baf54fb7ce1d5f2e1747ac628f6ffcf9543bce1c4833726680f7a402f8e6c35e39f93e0fce1c945b7672c4a9d
+MISC metadata.xml 167 SHA256 a96c7a7081b1a192fc4758c24f63e3f458ce37c90ef5594005e91e01a5daf934 SHA512 05f506754bd3182ba88befefe0609d354f9ee335bea2d866f30719b292ebae30dbe64d6c68ff1a918bfd380bd638146b30754d072229491e8ed6f9d6745510c9 WHIRLPOOL 59ac07478ebcd8bb8b5edba5af0041df85949cf69083c3aae6945e371e6b79c6c92e2bd21189b2d8a87de72c9a4cd299e0773ff73332e247f95b8e850a76d054
diff --git a/dev-python/Coffin/metadata.xml b/dev-python/Coffin/metadata.xml
new file mode 100644
index 000000000000..0645cd9ff8f3
--- /dev/null
+++ b/dev-python/Coffin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>