summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2010-02-16 05:07:11 +0000
committerSteve Dibb <beandog@gentoo.org>2010-02-16 05:07:11 +0000
commit375f9b22ca6158e7156834b3d9ce20727d1d21d1 (patch)
tree0b2d12386e029b9e97a92bc0b83e0d2707fa79df /dev-php
parentVersion bump (diff)
downloadgentoo-2-375f9b22ca6158e7156834b3d9ce20727d1d21d1.tar.gz
gentoo-2-375f9b22ca6158e7156834b3d9ce20727d1d21d1.tar.bz2
gentoo-2-375f9b22ca6158e7156834b3d9ce20727d1d21d1.zip
Version bump
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-PHP_Beautifier/ChangeLog10
-rw-r--r--dev-php/PEAR-PHP_Beautifier/PEAR-PHP_Beautifier-0.1.14.ebuild29
2 files changed, 37 insertions, 2 deletions
diff --git a/dev-php/PEAR-PHP_Beautifier/ChangeLog b/dev-php/PEAR-PHP_Beautifier/ChangeLog
index a6694f2f4bfb..2e186a03411a 100644
--- a/dev-php/PEAR-PHP_Beautifier/ChangeLog
+++ b/dev-php/PEAR-PHP_Beautifier/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/PEAR-PHP_Beautifier
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PHP_Beautifier/ChangeLog,v 1.2 2007/12/06 00:48:39 jokey Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PHP_Beautifier/ChangeLog,v 1.3 2010/02/16 05:07:11 beandog Exp $
+
+*PEAR-PHP_Beautifier-0.1.14 (16 Feb 2010)
+
+ 16 Feb 2010; Steve Dibb <beandog@gentoo.org>
+ +PEAR-PHP_Beautifier-0.1.14.ebuild:
+ Version bump
06 Dec 2007; Markus Ullmann <jokey@gentoo.org>
PEAR-PHP_Beautifier-0.1.13.ebuild:
diff --git a/dev-php/PEAR-PHP_Beautifier/PEAR-PHP_Beautifier-0.1.14.ebuild b/dev-php/PEAR-PHP_Beautifier/PEAR-PHP_Beautifier-0.1.14.ebuild
new file mode 100644
index 000000000000..ad1bb99f72c5
--- /dev/null
+++ b/dev-php/PEAR-PHP_Beautifier/PEAR-PHP_Beautifier-0.1.14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PHP_Beautifier/PEAR-PHP_Beautifier-0.1.14.ebuild,v 1.1 2010/02/16 05:07:11 beandog Exp $
+
+inherit php-pear-r1 depend.php eutils
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Code Beautifier for PHP."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-php/PEAR-Log-1.8"
+
+need_php5
+
+pkg_setup() {
+ require_php_with_use tokenizer
+}
+
+pkg_postinst() {
+ has_php
+ if ! built_with_use --missing true =${PHP_PKG} bzip2 ; then
+ elog "${PN} can optionally use bzip2 features."
+ elog "If you want those, emerge ${PHP_PKG} with this flag in USE."
+ fi
+}