summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-08-24 18:38:33 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-08-24 18:38:33 +0000
commit20634b26fb4c22d1a1a28aa8f35db2bc90695909 (patch)
treedeb605406bca68461e4961eca65c2d6347cf2472 /dev-php
parentnewer ati-drivers can be used with --force so we allow it (diff)
downloadgentoo-2-20634b26fb4c22d1a1a28aa8f35db2bc90695909.tar.gz
gentoo-2-20634b26fb4c22d1a1a28aa8f35db2bc90695909.tar.bz2
gentoo-2-20634b26fb4c22d1a1a28aa8f35db2bc90695909.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/xcache/ChangeLog7
-rw-r--r--dev-php/xcache/xcache-3.0.3.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-php/xcache/ChangeLog b/dev-php/xcache/ChangeLog
index fc6a728d75d7..234bca4ff849 100644
--- a/dev-php/xcache/ChangeLog
+++ b/dev-php/xcache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/xcache
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/ChangeLog,v 1.16 2013/04/17 12:52:36 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/ChangeLog,v 1.17 2013/08/24 18:38:33 olemarkus Exp $
+
+*xcache-3.0.3 (24 Aug 2013)
+
+ 24 Aug 2013; Ole Markus With <olemarkus@gentoo.org> +xcache-3.0.3.ebuild:
+ Version bump
17 Apr 2013; Ole Markus With <olemarkus@gentoo.org> -xcache-2.0.0.ebuild:
Remove old stable
diff --git a/dev-php/xcache/xcache-3.0.3.ebuild b/dev-php/xcache/xcache-3.0.3.ebuild
new file mode 100644
index 000000000000..5599b7a568c2
--- /dev/null
+++ b/dev-php/xcache/xcache-3.0.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/xcache/xcache-3.0.3.ebuild,v 1.1 2013/08/24 18:38:33 olemarkus Exp $
+
+EAPI="5"
+PHP_EXT_NAME="xcache"
+PHP_EXT_INI="yes"
+PHPSAPILIST="apache2 cgi fpm"
+
+USE_PHP="php5-4"
+inherit php-ext-source-r2 confutils
+
+DESCRIPTION="A fast and stable PHP opcode cacher"
+HOMEPAGE="http://xcache.lighttpd.net/"
+SRC_URI="http://xcache.lighttpd.net/pub/Releases/${PV}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# make test would just run php's test and as such need the full php source
+RESTRICT="test"
+
+DEPEND="virtual/httpd-php
+!dev-php/eaccelerator !dev-php/pecl-apc"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+
+ my_conf="--enable-xcache=shared \
+ --enable-xcache-constant \
+ --enable-xcache-optimizer \
+ --enable-xcache-coverager \
+ --enable-xcache-assembler \
+ --enable-xcache-encoder \
+ --enable-xcache-decoder"
+
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-source-r2_src_install
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins lib/Decompiler.class.php
+ insinto "${PHP_EXT_SHARED_DIR}"
+ doins -r htdocs
+}
+
+pkg_postinst() {
+ elog "lib/Decompiler.class.php, and the htdocs/ directory shipped with this"
+ elog "release were installed into ${PHP_EXT_SHARED_DIR}."
+}