summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2010-10-04 22:51:07 +0000
committerMarkus Ullmann <jokey@gentoo.org>2010-10-04 22:51:07 +0000
commitc08002ad61343b548e9f2fe617f3101477a08b71 (patch)
tree9733ec485ed746de693fb282df61b7246b23c751 /dev-php5
parentInitial import for phpunit-3.5 (diff)
downloadgentoo-2-c08002ad61343b548e9f2fe617f3101477a08b71.tar.gz
gentoo-2-c08002ad61343b548e9f2fe617f3101477a08b71.tar.bz2
gentoo-2-c08002ad61343b548e9f2fe617f3101477a08b71.zip
Version bump, now is splitted into pieces which have been added to cvs
also (Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/phpunit/ChangeLog8
-rw-r--r--dev-php5/phpunit/phpunit-3.5.0.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-php5/phpunit/ChangeLog b/dev-php5/phpunit/ChangeLog
index 14d43f05db8f..c919c21530c1 100644
--- a/dev-php5/phpunit/ChangeLog
+++ b/dev-php5/phpunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/phpunit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.28 2010/05/29 18:30:40 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/ChangeLog,v 1.29 2010/10/04 22:51:07 jokey Exp $
+
+*phpunit-3.5.0 (04 Oct 2010)
+
+ 04 Oct 2010; Markus Ullmann <jokey@gentoo.org> +phpunit-3.5.0.ebuild:
+ Version bump, now is splitted into pieces which have been added to cvs
+ also
*phpunit-3.4.13 (29 May 2010)
diff --git a/dev-php5/phpunit/phpunit-3.5.0.ebuild b/dev-php5/phpunit/phpunit-3.5.0.ebuild
new file mode 100644
index 000000000000..754d913dd89d
--- /dev/null
+++ b/dev-php5/phpunit/phpunit-3.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/phpunit/phpunit-3.5.0.ebuild,v 1.1 2010/10/04 22:51:07 jokey Exp $
+
+EAPI="2"
+inherit php-pear-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="Unit testing framework for PHP5"
+HOMEPAGE="http://www.phpunit.de/"
+SRC_URI="http://pear.phpunit.de/get/PHPUnit-${PV}.tgz"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+minimal"
+
+DEPEND="!dev-php4/phpunit
+ >=dev-php/PEAR-PEAR-1.9.1"
+RDEPEND="${DEPEND}
+ >=dev-lang/php-5.2[simplexml,xml,tokenizer]
+ || ( <dev-lang/php-5.3[pcre,reflection,spl] >=dev-lang/php-5.3 )
+ !minimal? ( >=dev-php5/xdebug-2.0.5
+ >=dev-php/PEAR-Image_GraphViz-1.2.1
+ >=dev-php/PEAR-Log-1.8.7-r1
+ dev-php5/PEAR-DbUnit
+ dev-php5/PEAR-File_Iterator
+ dev-php5/PEAR-PHP_CodeCoverage
+ dev-php5/PEAR-PHP_TokenStream
+ dev-php5/PEAR-PHP_Timer
+ dev-php5/phpunit-mockobject
+ dev-php5/phpunit-selenium )"
+
+need_php_by_category
+
+S="${WORKDIR}/PHPUnit-${PV}"
+
+pkg_postinst() {
+ has_php
+ elog "${PN} can optionally use json, pdo-sqlite and pdo-mysql features."
+ elog "If you want those, emerge ${PHP_PKG} with USE=\"json pdo sqlite mysql\"."
+ if use minimal; then
+ elog "You have enabled the minimal USE flag. If you want to use features"
+ elog "from xdebug, PEAR-Log or PEAR-Testing_Selenium disable the"
+ elog "USE flag or emerge the packages manually"
+ fi
+}