summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-01-06 20:52:35 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-01-06 20:52:35 +0000
commitb2052c455364899a887e8192d115d634040ca096 (patch)
tree1a3d812f2846519e6b4233993649492e081ceedf /dev-php5
parentResurrect libvirt-0.8.5-r2 (without keywords) for php-libvirt. (diff)
downloadgentoo-2-b2052c455364899a887e8192d115d634040ca096.tar.gz
gentoo-2-b2052c455364899a887e8192d115d634040ca096.tar.bz2
gentoo-2-b2052c455364899a887e8192d115d634040ca096.zip
Initial commit.
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/php-libvirt/ChangeLog10
-rw-r--r--dev-php5/php-libvirt/metadata.xml9
-rw-r--r--dev-php5/php-libvirt/php-libvirt-9999.ebuild35
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-php5/php-libvirt/ChangeLog b/dev-php5/php-libvirt/ChangeLog
new file mode 100644
index 000000000000..72f44e18d218
--- /dev/null
+++ b/dev-php5/php-libvirt/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php5/php-libvirt
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/php-libvirt/ChangeLog,v 1.1 2011/01/06 20:52:35 dev-zero Exp $
+
+*php-libvirt-9999 (06 Jan 2011)
+
+ 06 Jan 2011; Tiziano Müller <dev-zero@gentoo.org> +php-libvirt-9999.ebuild,
+ +metadata.xml:
+ Initial commit.
+
diff --git a/dev-php5/php-libvirt/metadata.xml b/dev-php5/php-libvirt/metadata.xml
new file mode 100644
index 000000000000..9f8438a7910f
--- /dev/null
+++ b/dev-php5/php-libvirt/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php5/php-libvirt/php-libvirt-9999.ebuild b/dev-php5/php-libvirt/php-libvirt-9999.ebuild
new file mode 100644
index 000000000000..7fccbc565a25
--- /dev/null
+++ b/dev-php5/php-libvirt/php-libvirt-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/php-libvirt/php-libvirt-9999.ebuild,v 1.1 2011/01/06 20:52:35 dev-zero Exp $
+
+EAPI=3
+
+PHP_EXT_NAME="libvirt"
+
+inherit php-ext-source-r2 subversion
+
+DESCRIPTION="PHP 5 bindings for libvirt."
+HOMEPAGE="http://libvirt-debian.vm.antab.is/book.libvirt.html"
+ESVN_REPO_URI="http://svn.antab.is/php-libvirt/trunk"
+
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="<app-emulation/libvirt-0.8.6"
+DEPEND="${DEPEND}
+ >=dev-util/re2c-0.13.5
+ dev-lang/php[cli]"
+
+src_unpack() {
+ subversion_src_unpack
+
+ for slot in $(php_get_slots); do
+ cp -r "${S}" "${WORKDIR}/${slot}"
+ done
+}
+
+src_prepare() {
+ php-ext-source-r2_src_prepare
+}