summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2009-09-13 14:28:56 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2009-09-13 14:28:56 +0000
commit09cc98204963409c46585e36e2e1d942b4a1e18b (patch)
tree410560b52e4a3c0935b395b52886f93ddd1a0b5b /dev-php5
parent* dev-php5/onphp-module masked - upstream is no longer supports it (diff)
downloadgentoo-2-09cc98204963409c46585e36e2e1d942b4a1e18b.tar.gz
gentoo-2-09cc98204963409c46585e36e2e1d942b4a1e18b.tar.bz2
gentoo-2-09cc98204963409c46585e36e2e1d942b4a1e18b.zip
* bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-php5')
-rw-r--r--dev-php5/onphp/ChangeLog10
-rw-r--r--dev-php5/onphp/onphp-1.0.9.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/dev-php5/onphp/ChangeLog b/dev-php5/onphp/ChangeLog
index 915604b20f21..c0ca3d10cebe 100644
--- a/dev-php5/onphp/ChangeLog
+++ b/dev-php5/onphp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/onphp
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/ChangeLog,v 1.63 2008/12/31 17:39:09 voxus Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/ChangeLog,v 1.64 2009/09/13 14:28:56 voxus Exp $
+
+*onphp-1.0.9 (13 Sep 2009)
+
+ 13 Sep 2009; Konstantin V. Arkhipov <voxus@gentoo.org>
+ +onphp-1.0.9.ebuild:
+ Version bump.
*onphp-1.0.8 (31 Dec 2008)
*onphp-0.10.13 (31 Dec 2008)
diff --git a/dev-php5/onphp/onphp-1.0.9.ebuild b/dev-php5/onphp/onphp-1.0.9.ebuild
new file mode 100644
index 000000000000..59ecfda4fcd6
--- /dev/null
+++ b/dev-php5/onphp/onphp-1.0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/onphp/onphp-1.0.9.ebuild,v 1.1 2009/09/13 14:28:56 voxus Exp $
+
+inherit php-lib-r1
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="onPHP is the LGPL'ed multi-purpose object-oriented PHP framework."
+HOMEPAGE="http://onphp.org/"
+SRC_URI="http://onphp.org/download/${P}.tar.bz2
+ doc? ( http://onphp.org/download/${PN}-api-${PV}.tar.bz2 )"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=""
+RDEPEND=""
+
+need_php_by_category
+
+src_install() {
+ has_php
+
+ dodoc `find doc -maxdepth 1 -type f -print`
+
+ if use doc ; then
+ dohtml -r "${WORKDIR}/${PN}-api-${PV}/"*
+ fi
+
+ php-lib-r1_src_install ./ global.inc.php.tpl
+ php-lib-r1_src_install ./ `find core main meta -type f -print`
+}