summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2007-10-28 12:11:15 +0000
committerMarkus Ullmann <jokey@gentoo.org>2007-10-28 12:11:15 +0000
commitecd2fba4d371791f6478f30eed5850aa24fe50b5 (patch)
tree8c27138dbeebc3c121a50953a7a464079d4590cf /dev-php5/xdebug
parentVersion bump from php project overlay (diff)
downloadgentoo-2-ecd2fba4d371791f6478f30eed5850aa24fe50b5.tar.gz
gentoo-2-ecd2fba4d371791f6478f30eed5850aa24fe50b5.tar.bz2
gentoo-2-ecd2fba4d371791f6478f30eed5850aa24fe50b5.zip
Version bump from php project overlay
(Portage version: 2.1.3.16)
Diffstat (limited to 'dev-php5/xdebug')
-rw-r--r--dev-php5/xdebug/ChangeLog10
-rw-r--r--dev-php5/xdebug/files/digest-xdebug-2.0.01
-rw-r--r--dev-php5/xdebug/files/digest-xdebug-2.0.13
-rw-r--r--dev-php5/xdebug/xdebug-2.0.1.ebuild79
4 files changed, 91 insertions, 2 deletions
diff --git a/dev-php5/xdebug/ChangeLog b/dev-php5/xdebug/ChangeLog
index 9a5cb54c8df4..12b477640ceb 100644
--- a/dev-php5/xdebug/ChangeLog
+++ b/dev-php5/xdebug/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php5/xdebug
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/ChangeLog,v 1.16 2007/09/11 19:35:46 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/ChangeLog,v 1.17 2007/10/28 12:11:14 jokey Exp $
+
+*xdebug-2.0.1 (28 Oct 2007)
+
+ 28 Oct 2007; Markus Ullmann <jokey@gentoo.org> +xdebug-2.0.1.ebuild:
+ Version bump from php project overlay
+
+ 27 Oct 2007; Jakub Moc <jakub@gentoo.org> +xdebug-2.0.1.ebuild:
+ Version bump
11 Sep 2007; Christian Hoffmann <hoffie@gentoo.org> xdebug-2.0.0.ebuild:
adjusting xdebug.profiler_output_name and xdebug.trace_output_name to fit
diff --git a/dev-php5/xdebug/files/digest-xdebug-2.0.0 b/dev-php5/xdebug/files/digest-xdebug-2.0.0
index f7bdf57c4831..0e29111cdd87 100644
--- a/dev-php5/xdebug/files/digest-xdebug-2.0.0
+++ b/dev-php5/xdebug/files/digest-xdebug-2.0.0
@@ -1,3 +1,2 @@
-MD5 0f9ecb9c5331d0041b04be9566763171 xdebug-2.0.0.tgz 272342
RMD160 1902f0b6227d3d8adfa3fc6bbc9cba06a604b2d4 xdebug-2.0.0.tgz 272342
SHA256 d29f393d4db1aa403200ac242614f86c06c1f111b290c4c8a612f8322e7f5660 xdebug-2.0.0.tgz 272342
diff --git a/dev-php5/xdebug/files/digest-xdebug-2.0.1 b/dev-php5/xdebug/files/digest-xdebug-2.0.1
new file mode 100644
index 000000000000..a8b9f96cc1cf
--- /dev/null
+++ b/dev-php5/xdebug/files/digest-xdebug-2.0.1
@@ -0,0 +1,3 @@
+MD5 d942de6225c5a06de7f693b672a44429 xdebug-2.0.1.tgz 279058
+RMD160 a958601000e9d02d20bdd773373befb867ba21b0 xdebug-2.0.1.tgz 279058
+SHA256 e844ee49637b731053bfda07670a9711a572ac7ad84d87ff889785432ebfa260 xdebug-2.0.1.tgz 279058
diff --git a/dev-php5/xdebug/xdebug-2.0.1.ebuild b/dev-php5/xdebug/xdebug-2.0.1.ebuild
new file mode 100644
index 000000000000..4d9ab61b6a31
--- /dev/null
+++ b/dev-php5/xdebug/xdebug-2.0.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/xdebug/xdebug-2.0.1.ebuild,v 1.1 2007/10/28 12:11:14 jokey Exp $
+
+PHP_EXT_NAME="xdebug"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
+
+inherit php-ext-source-r1
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+MY_PV="${PV/_/}"
+MY_PV="${MY_PV/rc/RC}"
+
+DESCRIPTION="A PHP Debugging and Profiling extension."
+HOMEPAGE="http://www.xdebug.org/"
+SRC_URI="http://pecl.php.net/get/${PN}-${MY_PV}.tgz"
+LICENSE="Xdebug"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DEPEND="!dev-php5/ZendOptimizer"
+RDEPEND="${DEPEND}
+ ~dev-php/xdebug-client-${PV}"
+
+need_php_by_category
+
+src_install() {
+ php-ext-source-r1_src_install
+ dodoc-php NEWS README Changelog CREDITS LICENSE
+
+ php-ext-base-r1_addtoinifiles "xdebug.auto_trace" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_output_dir" '"/tmp"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_output_name" '"trace.%c"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_format" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.trace_options" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_includes" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_params" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_return" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.collect_vars" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.default_enable" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.extended_info" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.manual_url" '"http://www.php.net"'
+ php-ext-base-r1_addtoinifiles "xdebug.max_nesting_level" '"100"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_exception_trace" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_local_vars" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.show_mem_delta" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.COOKIE" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.ENV" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.FILES" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.GET" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.POST" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.REQUEST" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.SERVER" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump.SESSION" '"NULL"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_globals" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_once" '"1"'
+ php-ext-base-r1_addtoinifiles "xdebug.dump_undefined" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_enable" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_output_dir" '"/tmp"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_output_name" '"cachegrind.out.%p"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_enable_trigger" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_append" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.profiler_aggregate" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_enable" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_handler" '"dbgp"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_host" '"localhost"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_mode" '"req"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_port" '"9000"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_autostart" '"0"'
+ php-ext-base-r1_addtoinifiles "xdebug.remote_log" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.idekey" '""'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_data" '"512"'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_depth" '"2"'
+ php-ext-base-r1_addtoinifiles "xdebug.var_display_max_children" '"128"'
+}