summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2005-12-18 01:39:43 +0000
committerLuca Longinotti <chtekk@gentoo.org>2005-12-18 01:39:43 +0000
commit45155759bb1c86d9e42a724dcaf76678ce8f3a66 (patch)
tree6effd75de112121cb78fce442db08341d6087bca /dev-php5/pecl-pdo
parentAdded patch to prevent overflow from Lluís Batlle i Rossell in bug #79312. (diff)
downloadgentoo-2-45155759bb1c86d9e42a724dcaf76678ce8f3a66.tar.gz
gentoo-2-45155759bb1c86d9e42a724dcaf76678ce8f3a66.tar.bz2
gentoo-2-45155759bb1c86d9e42a724dcaf76678ce8f3a66.zip
Sync with overlay.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-php5/pecl-pdo')
-rw-r--r--dev-php5/pecl-pdo/ChangeLog8
-rw-r--r--dev-php5/pecl-pdo/Manifest7
-rw-r--r--dev-php5/pecl-pdo/files/digest-pecl-pdo-0.91
-rw-r--r--dev-php5/pecl-pdo/files/digest-pecl-pdo-1.0.21
-rw-r--r--dev-php5/pecl-pdo/files/pdo_stmt.c.diff34
-rw-r--r--dev-php5/pecl-pdo/pecl-pdo-1.0.2.ebuild (renamed from dev-php5/pecl-pdo/pecl-pdo-0.9.ebuild)31
6 files changed, 23 insertions, 59 deletions
diff --git a/dev-php5/pecl-pdo/ChangeLog b/dev-php5/pecl-pdo/ChangeLog
index fd837a7ceb46..cee9071701e6 100644
--- a/dev-php5/pecl-pdo/ChangeLog
+++ b/dev-php5/pecl-pdo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php5/pecl-pdo
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo/ChangeLog,v 1.5 2005/11/19 19:31:07 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo/ChangeLog,v 1.6 2005/12/18 01:36:50 chtekk Exp $
+
+*pecl-pdo-1.0.2 (17 Dec 2005)
+
+ 17 Dec 2005; Luca Longinotti <chtekk@gentoo.org> -files/pdo_stmt.c.diff,
+ -pecl-pdo-0.9.ebuild, +pecl-pdo-1.0.2.ebuild:
+ Sync with overlay, update to 1.0.2 release.
19 Nov 2005; Markus Rothe <corsair@gentoo.org> pecl-pdo-0.9.ebuild:
Added ~ppc64 keyword; bug #102649
diff --git a/dev-php5/pecl-pdo/Manifest b/dev-php5/pecl-pdo/Manifest
index efdd237516ee..14de842f5178 100644
--- a/dev-php5/pecl-pdo/Manifest
+++ b/dev-php5/pecl-pdo/Manifest
@@ -1,5 +1,4 @@
-MD5 65f155e390f7bb3b580f29d04c9576d0 ChangeLog 773
+MD5 96b54760107bbaa3c3300dfffeee7856 ChangeLog 974
+MD5 acfecffdb99c7500e0cef13fc0536951 files/digest-pecl-pdo-1.0.2 57
MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
-MD5 f780dc77af4ec942b882a8e52cca9eaa pecl-pdo-0.9.ebuild 1598
-MD5 6279556cf34bf92200701c7a65f81ed9 files/digest-pecl-pdo-0.9 55
-MD5 c52b46703f8061eb524872fa24edc342 files/pdo_stmt.c.diff 915
+MD5 96984dde812f8af545c31ed17e3df2df pecl-pdo-1.0.2.ebuild 1462
diff --git a/dev-php5/pecl-pdo/files/digest-pecl-pdo-0.9 b/dev-php5/pecl-pdo/files/digest-pecl-pdo-0.9
deleted file mode 100644
index c1042eddf580..000000000000
--- a/dev-php5/pecl-pdo/files/digest-pecl-pdo-0.9
+++ /dev/null
@@ -1 +0,0 @@
-MD5 21e8200b0245a2513399a6b7c382b765 PDO-0.9.tgz 46682
diff --git a/dev-php5/pecl-pdo/files/digest-pecl-pdo-1.0.2 b/dev-php5/pecl-pdo/files/digest-pecl-pdo-1.0.2
new file mode 100644
index 000000000000..73a4bfb7dfc4
--- /dev/null
+++ b/dev-php5/pecl-pdo/files/digest-pecl-pdo-1.0.2
@@ -0,0 +1 @@
+MD5 171ab47eb4251ae1f3209e5919857792 PDO-1.0.2.tgz 49810
diff --git a/dev-php5/pecl-pdo/files/pdo_stmt.c.diff b/dev-php5/pecl-pdo/files/pdo_stmt.c.diff
deleted file mode 100644
index 06f433c01e51..000000000000
--- a/dev-php5/pecl-pdo/files/pdo_stmt.c.diff
+++ /dev/null
@@ -1,34 +0,0 @@
---- pdo_stmt.c 2005-07-27 04:06:11.000000000 +0200
-+++ pdo_stmt.c 2005-08-06 20:50:17.000000000 +0200
-@@ -18,7 +18,7 @@
- +----------------------------------------------------------------------+
- */
-
--/* $Id: pdo_stmt.c,v 1.116 2005/07/22 14:31:20 helly Exp $ */
-+/* $Id: pdo_stmt.c,v 1.118 2005/08/03 18:26:16 iliaa Exp $ */
-
- /* The PDO Statement Handle Class */
-
-@@ -1985,12 +1985,20 @@
- struct pdo_column_data *cols = stmt->columns;
-
- for (i = 0; i < stmt->column_count; i++) {
-- efree(cols[i].name);
-+ if (cols[i].name) {
-+ efree(cols[i].name);
-+ cols[i].name = NULL;
-+ }
- }
- efree(stmt->columns);
-+ stmt->columns = NULL;
-+ }
-+
-+ if (stmt->fetch.into && stmt->default_fetch_type == PDO_FETCH_INTO) {
-+ FREE_ZVAL(stmt->fetch.into);
-+ stmt->fetch.into = NULL;
- }
-
--
- do_fetch_opt_finish(stmt, 1 TSRMLS_CC);
-
- zend_objects_store_del_ref(&stmt->database_object_handle TSRMLS_CC);
diff --git a/dev-php5/pecl-pdo/pecl-pdo-0.9.ebuild b/dev-php5/pecl-pdo/pecl-pdo-1.0.2.ebuild
index ae1462ff8439..5d741b9800ff 100644
--- a/dev-php5/pecl-pdo/pecl-pdo-0.9.ebuild
+++ b/dev-php5/pecl-pdo/pecl-pdo-1.0.2.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo/pecl-pdo-0.9.ebuild,v 1.8 2005/11/19 19:31:07 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php5/pecl-pdo/pecl-pdo-1.0.2.ebuild,v 1.1 2005/12/18 01:36:50 chtekk Exp $
-PHP_EXT_ZENDEXT="no"
-PHP_EXT_PECL_PKG="PDO"
PHP_EXT_NAME="pdo"
+PHP_EXT_PECL_PKG="PDO"
PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
inherit php-ext-pecl-r1
-IUSE="firebird mssql mysql oci8 odbc postgres sqlite"
-DESCRIPTION="Core PHP Data Objects (PDO)"
-SLOT="0"
-LICENSE="PHP"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+DESCRIPTION="Core PHP Data Objects (PDO)."
+LICENSE="PHP"
+SLOT="0"
+IUSE="firebird mssql mysql oci8 oci8-instant-client odbc postgres sqlite"
+
PDEPEND="${PDEPEND}
firebird? ( dev-php5/pecl-pdo-firebird )
mssql? ( dev-php5/pecl-pdo-dblib )
mysql? ( dev-php5/pecl-pdo-mysql )
oci8? ( dev-php5/pecl-pdo-oci )
+ oci8-instant-client? ( dev-php5/pecl-pdo-oci )
odbc? ( dev-php5/pecl-pdo-odbc )
postgres? ( dev-php5/pecl-pdo-pgsql )
sqlite? ( dev-php5/pecl-pdo-sqlite )"
@@ -39,23 +41,14 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- # Patches the file to the newest CVS sources
- epatch ${FILESDIR}/pdo_stmt.c.diff
-}
-
src_install() {
php-ext-pecl-r1_src_install
# install missing header files
+ # usually done by "make install"
destdir=/usr/$(get_libdir)/php5
- dodir ${destdir}/include/php/ext/pdo
- insinto ${destdir}/include/php/ext/pdo
+ dodir "${destdir}/include/php/ext/pdo"
+ insinto "${destdir}/include/php/ext/pdo"
doins php_pdo_driver.h
doins php_pdo.h
- doins php_pdo_int.h
}