summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2006-02-02 06:35:05 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2006-02-02 06:35:05 +0000
commit2215a1775a9577920bc1e21a3109fd4d51aedc78 (patch)
tree2a05a455605a9028e1d4ff3d1ab8830771844b21 /dev-php4/pecl-memcache/pecl-memcache-2.0.1.ebuild
parentAdd tetex dependency for doc useflag, and make it decide whether to build doc... (diff)
downloadgentoo-2-2215a1775a9577920bc1e21a3109fd4d51aedc78.tar.gz
gentoo-2-2215a1775a9577920bc1e21a3109fd4d51aedc78.tar.bz2
gentoo-2-2215a1775a9577920bc1e21a3109fd4d51aedc78.zip
Version bump.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-php4/pecl-memcache/pecl-memcache-2.0.1.ebuild')
-rw-r--r--dev-php4/pecl-memcache/pecl-memcache-2.0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-php4/pecl-memcache/pecl-memcache-2.0.1.ebuild b/dev-php4/pecl-memcache/pecl-memcache-2.0.1.ebuild
new file mode 100644
index 000000000000..ed5613408a00
--- /dev/null
+++ b/dev-php4/pecl-memcache/pecl-memcache-2.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-memcache/pecl-memcache-2.0.1.ebuild,v 1.1 2006/02/02 06:35:05 sebastian Exp $
+
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+inherit php-ext-pecl-r1
+
+KEYWORDS="~ppc ~ppc64 ~sparc ~x86"
+DESCRIPTION="PHP extension for using memcached."
+LICENSE="PHP"
+SLOT="0"
+IUSE=""
+
+DEPEND="${DEPEND}
+ sys-libs/zlib"
+
+need_php_by_category
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ # fix bug #117990 better, without using a patch
+ # upstream has the file with CRLF instead of LF
+ edos2unix "${S}/config.m4"
+}
+
+src_compile() {
+ has_php
+
+ my_conf="--enable-memcache --with-zlib-dir=/usr"
+ php-ext-pecl-r1_src_compile
+}