summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-09-18 14:23:30 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-09-18 14:23:30 +0000
commit50e87f0cd3e758ea54669175e236264c01dea656 (patch)
treef9f12ce9f7ec44ee6ad6b6e408432fccc2c914e8 /dev-php4/jpgraph
parentAdded ~ppc64 (bug #106318) (diff)
downloadgentoo-2-50e87f0cd3e758ea54669175e236264c01dea656.tar.gz
gentoo-2-50e87f0cd3e758ea54669175e236264c01dea656.tar.bz2
gentoo-2-50e87f0cd3e758ea54669175e236264c01dea656.zip
php update
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-php4/jpgraph')
-rw-r--r--dev-php4/jpgraph/ChangeLog10
-rw-r--r--dev-php4/jpgraph/Manifest4
-rw-r--r--dev-php4/jpgraph/files/digest-jpgraph-1.191
-rw-r--r--dev-php4/jpgraph/jpgraph-1.19.ebuild82
-rw-r--r--dev-php4/jpgraph/metadata.xml5
5 files changed, 102 insertions, 0 deletions
diff --git a/dev-php4/jpgraph/ChangeLog b/dev-php4/jpgraph/ChangeLog
new file mode 100644
index 000000000000..13d93b079999
--- /dev/null
+++ b/dev-php4/jpgraph/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php4/jpgraph
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/jpgraph/ChangeLog,v 1.1 2005/09/18 14:23:30 hollow Exp $
+
+*jpgraph-1.19 (18 Sep 2005)
+
+ 18 Sep 2005; Benedikt Boehm <hollow@gentoo.org> +metadata.xml,
+ +jpgraph-1.19.ebuild:
+ initial version
+
diff --git a/dev-php4/jpgraph/Manifest b/dev-php4/jpgraph/Manifest
new file mode 100644
index 000000000000..758ece1edbb8
--- /dev/null
+++ b/dev-php4/jpgraph/Manifest
@@ -0,0 +1,4 @@
+MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
+MD5 242dcd28f0b6ab4a96aa096ea2e147f4 jpgraph-1.19.ebuild 2370
+MD5 33b01d6cf6392731f6b2e0fb7e8fb0d5 ChangeLog 254
+MD5 5808c16ea2ebf688f36553295fd2caee files/digest-jpgraph-1.19 65
diff --git a/dev-php4/jpgraph/files/digest-jpgraph-1.19 b/dev-php4/jpgraph/files/digest-jpgraph-1.19
new file mode 100644
index 000000000000..6eadd10a3e42
--- /dev/null
+++ b/dev-php4/jpgraph/files/digest-jpgraph-1.19
@@ -0,0 +1 @@
+MD5 fc364e1b56dea32bdace47411085cd72 jpgraph-1.19.tar.gz 4068179
diff --git a/dev-php4/jpgraph/jpgraph-1.19.ebuild b/dev-php4/jpgraph/jpgraph-1.19.ebuild
new file mode 100644
index 000000000000..8e873d20c5a1
--- /dev/null
+++ b/dev-php4/jpgraph/jpgraph-1.19.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/jpgraph/jpgraph-1.19.ebuild,v 1.1 2005/09/18 14:23:30 hollow Exp $
+
+inherit php-lib-r1
+
+DESCRIPTION="fully OO graph drawing library for PHP"
+HOMEPAGE="http://www.aditus.nu/jpgraph/"
+SRC_URI="http://members.chello.se/jpgraph/jpgdownloads/${P}.tar.gz"
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="truetype"
+
+RDEPEND="${RDEPEND}
+ truetype? ( media-fonts/corefonts )"
+
+need_php_by_category
+
+JPGRAPH_CACHE_DIR="/var/cache/jpgraph"
+COREFONTS_DIR="/usr/share/fonts/corefonts"
+
+pkg_setup() {
+ # we need the GD functionality of PHP
+ require_gd
+
+ # check to wich user:group the cache dir will go
+ if has_version "net-www/apache" ; then
+ HTTPD_USER=apache
+ HTTPD_GROUP=apache
+ einfo "Configuring cache dir ${JPGRAPH_CACHE_DIR} for Apache."
+ else
+ HTTPD_USER=root
+ HTTPD_GROUP=root
+ ewarn "No Apache webserver detected - ${JPGRAPH_CACHE_DIR} will be"
+ ewarn "owned by ${HTTPD_USER}:${HTTPD_GROUP} instead."
+ fi
+}
+
+src_install() {
+ # some patches to adapt the config to Gentoo
+ einfo "Patching jpg-config.inc"
+
+ # patch 1:
+ # make jpgraph use the correct group for file permissions
+
+ sed -i "s|^DEFINE(\"CACHE_FILE_GROUP\",\"wwwadmin\");|DEFINE(\"CACHE_FILE_GROUP\",\"${HTTPD_GROUP}\");|" src/jpg-config.inc
+
+ # patch 2:
+ # make jpgraph use the correct directory for caching
+
+ sed -i "s|.*DEFINE(\"CACHE_DIR\",\"/tmp/jpgraph_cache/\");|DEFINE(\"CACHE_DIR\",\"${JPGRAPH_CACHE_DIR}/\");|" src/jpg-config.inc
+
+ # patch 3:
+ # make jpgraph use the correct directory for the corefonts if the truetype USE flag is set
+
+ if use truetype ; then
+ sed -i "s|.*DEFINE(\"TTF_DIR\",\"/usr/X11R6/lib/X11/fonts/truetype/\");|DEFINE(\"TTF_DIR\",\"${COREFONTS_DIR}/\");|" src/jpg-config.inc
+ fi
+
+ # patch 4:
+ # disable READ_CACHE in jpgraph
+
+ sed -i "s|^DEFINE(\"READ_CACHE\",true);|DEFINE(\"READ_CACHE\",false);|" src/jpg-config.inc
+
+ # install php files
+ einfo "Building list of files to install"
+ php-lib-r1_src_install src `cd src ; find . -type f -print`
+
+ # install documentation
+ einfo "Installing documentation"
+ dodoc README QPL.txt
+ dohtml -r docs/*
+
+ # setup the cache dir
+ # cachedir must be world-writable, because PHP/CLI doesn't run
+ # as the apache user!
+ einfo "Setting up the cache dir"
+ keepdir "${JPGRAPH_CACHE_DIR}"
+ fowners ${HTTPD_USER}:${HTTPD_GROUP} "${JPGRAPH_CACHE_DIR}"
+ fperms 700 "${JPGRAPH_CACHE_DIR}"
+}
diff --git a/dev-php4/jpgraph/metadata.xml b/dev-php4/jpgraph/metadata.xml
new file mode 100644
index 000000000000..fd3dbe39fa64
--- /dev/null
+++ b/dev-php4/jpgraph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+</pkgmetadata>