summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTal Peer <coredumb@gentoo.org>2003-07-30 08:53:35 +0000
committerTal Peer <coredumb@gentoo.org>2003-07-30 08:53:35 +0000
commite358aeeb273c64ded1ebbf8ea2af177fcdf6406c (patch)
tree3490dbd9fb25287ab2f0fb51a7968db9ffd30567 /dev-php/php
parentDropped cjk from IUSE. Now mbstring and mbregex are always enabled. (diff)
downloadgentoo-2-e358aeeb273c64ded1ebbf8ea2af177fcdf6406c.tar.gz
gentoo-2-e358aeeb273c64ded1ebbf8ea2af177fcdf6406c.tar.bz2
gentoo-2-e358aeeb273c64ded1ebbf8ea2af177fcdf6406c.zip
Dropped cjk from IUSE. Now mbstring and mbregex are always enabled.
Diffstat (limited to 'dev-php/php')
-rw-r--r--dev-php/php/ChangeLog6
-rw-r--r--dev-php/php/Manifest4
-rw-r--r--dev-php/php/files/digest-php-4.3.2-r32
-rw-r--r--dev-php/php/php-4.3.2-r3.ebuild53
4 files changed, 62 insertions, 3 deletions
diff --git a/dev-php/php/ChangeLog b/dev-php/php/ChangeLog
index a748618c747c..37e28124601c 100644
--- a/dev-php/php/ChangeLog
+++ b/dev-php/php/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/php
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.53 2003/07/21 07:28:35 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/ChangeLog,v 1.54 2003/07/30 08:53:20 coredumb Exp $
+
+*php-4.3.2-r3 (30 Jul 2003)
+ 30 Jul 2003; Tal Peer <coredumb@gentoo.org> php-4.3.2-r3.ebuild:
+ Dropped cjk from IUSE. Now mbstring and mbregex are always enabled.
*php-5.0_beta1 (14 Jul 2003)
diff --git a/dev-php/php/Manifest b/dev-php/php/Manifest
index 95b5f789261e..5202886ef32a 100644
--- a/dev-php/php/Manifest
+++ b/dev-php/php/Manifest
@@ -1,9 +1,9 @@
-MD5 9bf044a23a650a784726eb9e54a3a185 ChangeLog 8261
+MD5 43f420b888f3e948ee14feccb76ce540 ChangeLog 8428
MD5 7588d047b95d706759df29bdafceb4cf php-4.3.2-r1.ebuild 992
MD5 0ad96393a56530df42b3aca284635593 php-5.0_beta1.ebuild 1179
MD5 5541cf4177bfcf205012ed0da4cd38c0 php-4.3.2.ebuild 2423
MD5 8893110f384462d0082e4171222ad880 php-4.3.2-r2.ebuild 1185
-MD5 8902689455e15cd8a48519a75d11dcde php-4.3.2-r3.ebuild 1186
+MD5 e81b32f1d8bfc1d5ab5e0d4ca26360e0 php-4.3.2-r3.ebuild 1187
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r1 137
MD5 2a7311fb659555c4711a4ed8b70e9594 files/digest-php-5.0_beta1 65
MD5 63f7765d77e10eeef4b306480cd5d200 files/digest-php-4.3.2-r2 137
diff --git a/dev-php/php/files/digest-php-4.3.2-r3 b/dev-php/php/files/digest-php-4.3.2-r3
new file mode 100644
index 000000000000..b16a849236e0
--- /dev/null
+++ b/dev-php/php/files/digest-php-4.3.2-r3
@@ -0,0 +1,2 @@
+MD5 8aec1bb2dbcca1c92835c71e2e30d9c5 php-4.3.2.tar.bz2 3697581
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
diff --git a/dev-php/php/php-4.3.2-r3.ebuild b/dev-php/php/php-4.3.2-r3.ebuild
new file mode 100644
index 000000000000..d102c6e1aaea
--- /dev/null
+++ b/dev-php/php/php-4.3.2-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php/php-4.3.2-r3.ebuild,v 1.1 2003/07/30 08:53:20 coredumb Exp $
+
+PHPSAPI="cli"
+inherit php eutils
+
+IUSE="${IUSE} readline"
+
+DESCRIPTION="PHP Shell Interpreter"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~mips"
+
+DEPEND="${DEPEND}
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ ncurses? ( >=sys-libs/ncurses-5.1 )"
+
+RDEPEND="${RDEPEND}"
+
+src_compile() {
+ php_securityupgrade
+
+ # Readline and Ncurses are CLI PHP only
+ use ncurses || use readline && use_ncurses="--with-" || use_ncurses="--without-"
+ myconf="${myconf} `use_with readline`"
+ myconf="${myconf} ${use_ncurses}-ncurses"
+
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli"
+
+ php_src_compile
+}
+
+
+src_install() {
+ installtargets="${installtargets} install-cli"
+ php_src_install
+
+ # php executable is located in ./sapi/cli/
+ exeinto /usr/bin
+ doexe sapi/cli/php
+}
+
+pkg_postinst() {
+ php_pkg_postinst
+ php_securityupgrade
+ einfo "This is a CLI only build."
+ einfo "You can not use it on a webserver."
+}
+pkg_preinst() {
+ php_pkg_preinst
+}