summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-11-16 12:23:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-11-16 12:23:37 +0000
commitb75127f4332cf01586089c77e1074fff67089a9f (patch)
treea229e46f8d43170212594e6e22e97888ae7d56bf /dev-php/php-core
parentinitial commit of new split-up php (diff)
downloadgentoo-2-b75127f4332cf01586089c77e1074fff67089a9f.tar.gz
gentoo-2-b75127f4332cf01586089c77e1074fff67089a9f.tar.bz2
gentoo-2-b75127f4332cf01586089c77e1074fff67089a9f.zip
initial commit of new split-up php
Diffstat (limited to 'dev-php/php-core')
-rw-r--r--dev-php/php-core/ChangeLog10
-rw-r--r--dev-php/php-core/Manifest4
-rw-r--r--dev-php/php-core/files/digest-php-core-4.3.43
-rw-r--r--dev-php/php-core/metadata.xml10
-rw-r--r--dev-php/php-core/php-core-4.3.4.ebuild66
5 files changed, 92 insertions, 1 deletions
diff --git a/dev-php/php-core/ChangeLog b/dev-php/php-core/ChangeLog
new file mode 100644
index 000000000000..c5687e8bc521
--- /dev/null
+++ b/dev-php/php-core/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-php/php-core
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-core/ChangeLog,v 1.1 2003/11/16 12:23:35 robbat2 Exp $
+
+*php-core-4.3.4 (16 Nov 2003)
+
+ 16 Nov 2003; Robin H. Johnson <robbat2@gentoo.org> php-core-4.3.4.ebuild,
+ metadata.xml:
+ initial commit of new split-up php
+
diff --git a/dev-php/php-core/Manifest b/dev-php/php-core/Manifest
index cb6a9ac2bbf6..1eeedef7bb23 100644
--- a/dev-php/php-core/Manifest
+++ b/dev-php/php-core/Manifest
@@ -1,2 +1,4 @@
-MD5 77c07a102e1fac4a4690256c1b9cf262 php-core-4.3.4.ebuild 1151
+MD5 a5576a61f0c8426208339092087b7e9f php-core-4.3.4.ebuild 1939
+MD5 4363b8ada7f3f18466fa896a1fefc975 ChangeLog 375
+MD5 38fe937e954ab7109395cefa86fcd2d4 metadata.xml 384
MD5 85d30f5e2707a53bd35b201a29371f05 files/digest-php-core-4.3.4 208
diff --git a/dev-php/php-core/files/digest-php-core-4.3.4 b/dev-php/php-core/files/digest-php-core-4.3.4
new file mode 100644
index 000000000000..2f7602289366
--- /dev/null
+++ b/dev-php/php-core/files/digest-php-core-4.3.4
@@ -0,0 +1,3 @@
+MD5 b9dd601863e08e52e3c4d5e02c2627cf php-4.3.4.tar.bz2 3774324
+MD5 912ff94309b762563d0542db5187315f php-4.3.2-fopen-url-secure.patch 416
+MD5 a5dd907ca0aed4ba38c79181d407cbff php-4.3.4-phpizeexecfix.patch 386
diff --git a/dev-php/php-core/metadata.xml b/dev-php/php-core/metadata.xml
new file mode 100644
index 000000000000..f1ebb2203ac7
--- /dev/null
+++ b/dev-php/php-core/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>php</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ <description>Eclass author and primary maintainer (See the herd for other maintainers)</description>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-php/php-core/php-core-4.3.4.ebuild b/dev-php/php-core/php-core-4.3.4.ebuild
new file mode 100644
index 000000000000..69f5565beb9d
--- /dev/null
+++ b/dev-php/php-core/php-core-4.3.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-core/php-core-4.3.4.ebuild,v 1.1 2003/11/16 12:23:35 robbat2 Exp $
+
+PHPSAPI="cli"
+inherit php-2 eutils
+
+IUSE="${IUSE} readline"
+
+DESCRIPTION="PHP core package"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm ~hppa ~mips"
+
+DEPEND_EXTRA="readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ ncurses? ( >=sys-libs/ncurses-5.1 )
+ >=virtual/php-4.3.4
+ ~virtual/php-${PV}"
+DEPEND="${DEPEND} ${DEPEND_EXTRA}"
+RDEPEND="${RDEPEND} ${DEPEND_EXTRA}"
+
+src_compile() {
+ if has_version 'dev-php/php' && [ -x '/usr/bin/php' ]; then
+ # Ok, so we can cheat and not have to build all of it...
+ cp /usr/bin/php ${S}/sapi/cli/php
+ PHP_SKIP_MAKE=1
+ einfo "You have dev-php/php installed, so we're cheating and using it"
+ einfo "instead of rebuilding the CLI SAPI to make PEAR packages."
+ einfo "configure will still be run to build the required Makefiles."
+ else
+ ewarn "Since you don't have dev-php/php installed, we need to build"
+ ewarn "the PHP CLI interpreter to make the PEAR packages."
+ fi
+
+ # the rest of this should be identical to dev-php/php
+ myconf="${myconf} `use_with readline readline /usr`"
+ # Readline and Ncurses are CLI PHP only
+ # readline needs ncurses
+ use ncurses || use readline \
+ && myconf="${myconf} --with-ncurses=/usr" \
+ || myconf="${myconf} --without-ncurses"
+
+ myconf="${myconf} \
+ --disable-cgi \
+ --enable-cli"
+
+ php_src_compile
+}
+
+
+src_install() {
+ # make sure the possibly faked PHP is in place and new enough to avoid build storms
+ touch ${S}/sapi/cli/php
+ PHP_INSTALLTARGETS="install-programs install-pear install-build install-headers"
+ PHP_SKIP_BUILD=1
+ php_src_install
+ #rm -rf ${D}/etc/php4 ${D}/etc/php
+}
+
+pkg_postinst() {
+ einfo "This is a limited build to provide PEAR and build utilities"
+}
+
+pkg_preinst() {
+ #php_pkg_preinst
+ :
+}