summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-04-07 17:49:45 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-04-07 17:49:45 +0000
commit5acab1cea9296d96b0f16dc0d7c016d45996b012 (patch)
tree74e0e7c2657ead4579694311fea9a891c3da9df5 /dev-php/pecl-memcache
parentGuard against multiple inheritance. Make KMCOMPILEONLY sed case-insensitive t... (diff)
downloadgentoo-2-5acab1cea9296d96b0f16dc0d7c016d45996b012.tar.gz
gentoo-2-5acab1cea9296d96b0f16dc0d7c016d45996b012.tar.bz2
gentoo-2-5acab1cea9296d96b0f16dc0d7c016d45996b012.zip
Version bump. Bug 464484
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'dev-php/pecl-memcache')
-rw-r--r--dev-php/pecl-memcache/ChangeLog8
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild41
-rw-r--r--dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild4
3 files changed, 50 insertions, 3 deletions
diff --git a/dev-php/pecl-memcache/ChangeLog b/dev-php/pecl-memcache/ChangeLog
index 71bb3240094f..9dbde8fb439a 100644
--- a/dev-php/pecl-memcache/ChangeLog
+++ b/dev-php/pecl-memcache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/pecl-memcache
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/ChangeLog,v 1.8 2013/03/05 09:40:36 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/ChangeLog,v 1.9 2013/04/07 17:49:45 olemarkus Exp $
+
+*pecl-memcache-2.2.7 (07 Apr 2013)
+
+ 07 Apr 2013; Ole Markus With <olemarkus@gentoo.org>
+ +pecl-memcache-2.2.7.ebuild, pecl-memcache-3.0.7.ebuild:
+ Version bump. Bug 464484
05 Mar 2013; Ole Markus With <olemarkus@gentoo.org>
-pecl-memcache-3.0.5-r1.ebuild, -pecl-memcache-3.0.6-r1.ebuild:
diff --git a/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild b/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild
new file mode 100644
index 000000000000..4d7ec9456b3d
--- /dev/null
+++ b/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-2.2.7.ebuild,v 1.1 2013/04/07 17:49:45 olemarkus Exp $
+
+EAPI="4"
+PHP_EXT_NAME="memcache"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="README"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for using memcached."
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="+session"
+
+DEPEND="sys-libs/zlib
+ dev-lang/php[session?]"
+RDEPEND="${DEPEND}"
+
+# upstream does not ship any testsuite, so the PHPize test-runner fails.
+RESTRICT='test'
+
+src_configure() {
+ my_conf="--enable-memcache --with-zlib-dir=/usr $(use_enable session memcache-session)"
+ php-ext-source-r2_src_configure
+}
+
+src_install() {
+ php-ext-pecl-r2_src_install
+
+ php-ext-source-r2_addtoinifiles "memcache.allow_failover" "true"
+ php-ext-source-r2_addtoinifiles "memcache.max_failover_attempts" "20"
+ php-ext-source-r2_addtoinifiles "memcache.chunk_size" "32768"
+ php-ext-source-r2_addtoinifiles "memcache.default_port" "11211"
+ php-ext-source-r2_addtoinifiles "memcache.hash_strategy" "standard"
+ php-ext-source-r2_addtoinifiles "memcache.hash_function" "crc32"
+}
diff --git a/dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild b/dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild
index da3b4044a0a3..02ba5c86e6ab 100644
--- a/dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild
+++ b/dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild,v 1.1 2013/03/04 09:22:21 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-memcache/pecl-memcache-3.0.7.ebuild,v 1.2 2013/04/07 17:49:45 olemarkus Exp $
EAPI="5"
PHP_EXT_NAME="memcache"
@@ -8,7 +8,7 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS="README"
-USE_PHP="php5-3 php5-4"
+USE_PHP="php5-5 php5-3 php5-4"
inherit php-ext-pecl-r2