summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-06-17 13:09:20 +0000
committerMatti Bickel <mabi@gentoo.org>2010-06-17 13:09:20 +0000
commit7aa11e91e0659eb2eadc0968ed3d6f65d30145ca (patch)
treea9477e5842cfcc905d5bd807c314e93b845ec726 /dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.1-r1.ebuild
parentFix typo. (diff)
downloadgentoo-2-7aa11e91e0659eb2eadc0968ed3d6f65d30145ca.tar.gz
gentoo-2-7aa11e91e0659eb2eadc0968ed3d6f65d30145ca.tar.bz2
gentoo-2-7aa11e91e0659eb2eadc0968ed3d6f65d30145ca.zip
eapi bump
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.1-r1.ebuild')
-rw-r--r--dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.1-r1.ebuild b/dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..73e656c3d31b
--- /dev/null
+++ b/dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/PEAR-PHP_Shell/PEAR-PHP_Shell-0.3.1-r1.ebuild,v 1.1 2010/06/17 13:09:20 mabi Exp $
+
+EAPI="2"
+
+inherit php-pear-r1
+
+DESCRIPTION="A shell for PHP with history and tab-completion"
+HOMEPAGE="http://jan.kneschke.de/projects/php-shell/"
+SRC_URI="http://jan.kneschke.de/assets/2007/2/17/${PEAR_PN}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="auto-completion"
+
+DEPEND="|| ( <dev-lang/php-5.3[pcre,spl,tokenizer] >=dev-lang/php-5.3[tokenizer] )
+ auto-completion? ( dev-lang/php[readline] )"
+
+src_install() {
+ php-pear-r1_src_install
+ dosym /usr/bin/php-shell.sh /usr/bin/php-shell
+}