summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-12-01 20:18:20 +0000
committerTorsten Veller <tove@gentoo.org>2011-12-01 20:18:20 +0000
commitdfe6c1ec48b7dad21e7609585a9d2ffda1f3f069 (patch)
tree958e8f4fb539c731b9383f788101b29cce8c101d /dev-perl
parentMinor retouches and forwarding the changes to the live ebuild, thanks a lot t... (diff)
downloadgentoo-2-dfe6c1ec48b7dad21e7609585a9d2ffda1f3f069.tar.gz
gentoo-2-dfe6c1ec48b7dad21e7609585a9d2ffda1f3f069.tar.bz2
gentoo-2-dfe6c1ec48b7dad21e7609585a9d2ffda1f3f069.zip
Add missing RDEPEND. Thanks to Tiziano Müller
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/GD/ChangeLog5
-rw-r--r--dev-perl/GD/GD-2.460.0.ebuild17
2 files changed, 13 insertions, 9 deletions
diff --git a/dev-perl/GD/ChangeLog b/dev-perl/GD/ChangeLog
index 460bb15665e6..a3c58a0bab38 100644
--- a/dev-perl/GD/ChangeLog
+++ b/dev-perl/GD/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-perl/GD
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/ChangeLog,v 1.100 2011/07/30 08:18:03 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/ChangeLog,v 1.101 2011/12/01 20:18:20 tove Exp $
+
+ 01 Dec 2011; Torsten Veller <tove@gentoo.org> GD-2.460.0.ebuild:
+ Add missing RDEPEND. Thanks to Tiziano Müller
30 Jul 2011; Torsten Veller <tove@gentoo.org> -GD-2.45-r1.ebuild:
Cleanup
diff --git a/dev-perl/GD/GD-2.460.0.ebuild b/dev-perl/GD/GD-2.460.0.ebuild
index 8c5afc2d5c03..5313ca6cd172 100644
--- a/dev-perl/GD/GD-2.460.0.ebuild
+++ b/dev-perl/GD/GD-2.460.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/GD-2.460.0.ebuild,v 1.1 2011/05/02 18:49:15 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/GD-2.460.0.ebuild,v 1.2 2011/12/01 20:18:20 tove Exp $
EAPI=4
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
IUSE="animgif gif jpeg png truetype xpm"
-DEPEND=">=media-libs/gd-2.0.33
+RDEPEND=">=media-libs/gd-2.0.33
png? (
media-libs/gd[png]
media-libs/libpng
@@ -34,6 +34,7 @@ DEPEND=">=media-libs/gd-2.0.33
x11-libs/libXpm
)
gif? ( media-libs/giflib )"
+DEPEND="${RDEPEND}"
SRC_TEST=do
@@ -45,12 +46,12 @@ src_prepare(){
src_configure() {
myconf=""
- use gif && use animgif && myconf="${myconf},ANIMGIF"
- use jpeg && myconf="${myconf},JPEG"
- use truetype && myconf="${myconf},FREETYPE"
- use png && myconf="${myconf},PNG"
- use xpm && myconf="${myconf},XPM"
- use gif && myconf="${myconf},GIF"
+ use gif && use animgif && myconf+=",ANIMGIF"
+ use jpeg && myconf+=",JPEG"
+ use truetype && myconf+=",FREETYPE"
+ use png && myconf+=",PNG"
+ use xpm && myconf+=",XPM"
+ use gif && myconf+=",GIF"
myconf="-options \"${myconf:1}\""
perl-module_src_configure
}