summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-10 10:29:50 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-10 10:29:50 +0000
commit4be2308298b69eefa104c234be9c8c89f651bc37 (patch)
treef54739f4a7269e222176540ad9449fef39b8c01e /dev-perl/sdl-perl/sdl-perl-2.2.6.ebuild
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-4be2308298b69eefa104c234be9c8c89f651bc37.tar.gz
gentoo-2-4be2308298b69eefa104c234be9c8c89f651bc37.tar.bz2
gentoo-2-4be2308298b69eefa104c234be9c8c89f651bc37.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/sdl-perl/sdl-perl-2.2.6.ebuild')
-rw-r--r--dev-perl/sdl-perl/sdl-perl-2.2.6.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/sdl-perl/sdl-perl-2.2.6.ebuild b/dev-perl/sdl-perl/sdl-perl-2.2.6.ebuild
new file mode 100644
index 000000000000..fa6a25d0aa50
--- /dev/null
+++ b/dev-perl/sdl-perl/sdl-perl-2.2.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/sdl-perl/sdl-perl-2.2.6.ebuild,v 1.1 2009/11/10 10:29:50 robbat2 Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=KTHAKORE
+MY_PN=SDL_Perl
+MY_P=${MY_PN}-v${PV}
+inherit perl-module
+
+DESCRIPTION="SDL binding for perl"
+HOMEPAGE="http://sdl.perl.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="truetype mpeg"
+
+# Only enable this if you are confirming a bug in this module. The testsrequire
+# access to your /dev/{snd,sound} devices.
+#SRC_TEST="do"
+
+RDEPEND="virtual/opengl
+ >=media-libs/libsdl-1.2.6
+ >=media-libs/sdl-mixer-1.2.5
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-gfx-2.0.3
+ >=media-libs/sdl-net-1.2.4
+ mpeg? ( media-libs/smpeg )
+ truetype? ( >=media-libs/sdl-ttf-2.0.5 )
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-CBuilder
+ >=virtual/perl-Module-Build-0.28"
+
+S=${WORKDIR}/${MY_P}
+
+myconf="--extra_linker_flags='${LDFLAGS}'"