summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-04-19 09:26:18 +0000
committerTorsten Veller <tove@gentoo.org>2009-04-19 09:26:18 +0000
commita24f6ab8e082ac26c43f165b645155ff9bd39888 (patch)
tree42c56be6a293a741da0c3ca11283b5b0b20dc35b /dev-perl/math-pari
parentMask =dev-perl/math-pari-2.010801-r1 for testing (diff)
downloadgentoo-2-a24f6ab8e082ac26c43f165b645155ff9bd39888.tar.gz
gentoo-2-a24f6ab8e082ac26c43f165b645155ff9bd39888.tar.bz2
gentoo-2-a24f6ab8e082ac26c43f165b645155ff9bd39888.zip
Update sci-mathematics/pari dependency to 2.3.4
(Portage version: 2.2_rc30/cvs/Linux i686)
Diffstat (limited to 'dev-perl/math-pari')
-rw-r--r--dev-perl/math-pari/ChangeLog8
-rw-r--r--dev-perl/math-pari/math-pari-2.010801-r1.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index 9ec979a14ab8..6871d66156e9 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/math-pari
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.42 2009/02/23 10:05:58 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.43 2009/04/19 09:26:18 tove Exp $
+
+*math-pari-2.010801-r1 (19 Apr 2009)
+
+ 19 Apr 2009; Torsten Veller <tove@gentoo.org>
+ +math-pari-2.010801-r1.ebuild:
+ Update sci-mathematics/pari dependency to 2.3.4
*math-pari-2.010801 (23 Feb 2009)
diff --git a/dev-perl/math-pari/math-pari-2.010801-r1.ebuild b/dev-perl/math-pari/math-pari-2.010801-r1.ebuild
new file mode 100644
index 000000000000..4ba2e1c56d4a
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.010801-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.010801-r1.ebuild,v 1.1 2009/04/19 09:26:18 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=ILYAZ
+MODULE_SECTION=modules
+MY_PN=Math-Pari
+MY_P=${MY_PN}-${PV}
+inherit perl-module
+
+PARI_VER=2.3.4
+
+DESCRIPTION="Perl interface to PARI"
+SRC_URI="${SRC_URI}
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-${PARI_VER}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+RDEPEND="~sci-mathematics/pari-${PARI_VER}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+SRC_TEST=do
+
+src_configure() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that
+ # pulls in the math-pari module as DynaLoader cannot load the resulting
+ # .so files math-pari generates. As such, we have to use the generic
+ # non-machine specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
+
+ perl-module_src_configure
+}