summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-01-27 03:32:57 +0000
committerDonny Davies <woodchip@gentoo.org>2002-01-27 03:32:57 +0000
commitf2f08edca74ef6a26bcf64fcd8f74645c0666a96 (patch)
tree48e58cd5f138af279547ca668819175720418c84 /dev-perl/RPM
parentinitial checkin (diff)
downloadgentoo-2-f2f08edca74ef6a26bcf64fcd8f74645c0666a96.tar.gz
gentoo-2-f2f08edca74ef6a26bcf64fcd8f74645c0666a96.tar.bz2
gentoo-2-f2f08edca74ef6a26bcf64fcd8f74645c0666a96.zip
initial checkin
Diffstat (limited to 'dev-perl/RPM')
-rw-r--r--dev-perl/RPM/RPM-0.32.ebuild30
-rw-r--r--dev-perl/RPM/files/digest-RPM-0.321
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/RPM/RPM-0.32.ebuild b/dev-perl/RPM/RPM-0.32.ebuild
new file mode 100644
index 000000000000..72b66994a443
--- /dev/null
+++ b/dev-perl/RPM/RPM-0.32.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/RPM/RPM-0.32.ebuild,v 1.1 2002/01/27 03:32:57 woodchip Exp $
+
+S=${WORKDIR}/Perl-${P}
+DESCRIPTION="RPM:: module for perl"
+SRC_URI="http://www.cpan.org/authors/id/RJRAY/Perl-${P}.tar.gz"
+
+DEPEND="virtual/glibc >=sys-devel/perl-5 app-arch/rpm"
+
+src_compile() {
+
+ OPTIMIZE="$CFLAGS" perl Makefile.PL /usr
+ make || die
+}
+
+src_install () {
+
+ eval `perl '-V:installarchlib'`
+ mkdir -p ${D}/$installarchlib
+
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ install || die
+
+ dodoc ChangeLog MANIFEST README ToDo
+}
diff --git a/dev-perl/RPM/files/digest-RPM-0.32 b/dev-perl/RPM/files/digest-RPM-0.32
new file mode 100644
index 000000000000..7eea2a3aa4cb
--- /dev/null
+++ b/dev-perl/RPM/files/digest-RPM-0.32
@@ -0,0 +1 @@
+MD5 309fa727a60f140b318f939481cb9e84 Perl-RPM-0.32.tar.gz 57344