summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-04-17 11:20:04 +0000
committerTorsten Veller <tove@gentoo.org>2010-04-17 11:20:04 +0000
commit03cbb870fba9a16f018d929f79cc8129094801c6 (patch)
treeb90c2fe2b7f7b728c147a82e452884a086fc6dbf /dev-perl/Panotools-Script
parentCommit jkt's change for the build sytem. (diff)
downloadgentoo-2-03cbb870fba9a16f018d929f79cc8129094801c6.tar.gz
gentoo-2-03cbb870fba9a16f018d929f79cc8129094801c6.tar.bz2
gentoo-2-03cbb870fba9a16f018d929f79cc8129094801c6.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Panotools-Script')
-rw-r--r--dev-perl/Panotools-Script/ChangeLog8
-rw-r--r--dev-perl/Panotools-Script/Panotools-Script-0.25.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-perl/Panotools-Script/ChangeLog b/dev-perl/Panotools-Script/ChangeLog
index f0bd7b25baee..34c746da4766 100644
--- a/dev-perl/Panotools-Script/ChangeLog
+++ b/dev-perl/Panotools-Script/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Panotools-Script
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Panotools-Script/ChangeLog,v 1.3 2010/04/09 07:37:37 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Panotools-Script/ChangeLog,v 1.4 2010/04/17 11:20:04 tove Exp $
+
+*Panotools-Script-0.25 (17 Apr 2010)
+
+ 17 Apr 2010; Torsten Veller <tove@gentoo.org>
+ +Panotools-Script-0.25.ebuild:
+ Version bump
09 Apr 2010; Torsten Veller <tove@gentoo.org>
-Panotools-Script-0.23.ebuild:
diff --git a/dev-perl/Panotools-Script/Panotools-Script-0.25.ebuild b/dev-perl/Panotools-Script/Panotools-Script-0.25.ebuild
new file mode 100644
index 000000000000..7f788207a132
--- /dev/null
+++ b/dev-perl/Panotools-Script/Panotools-Script-0.25.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Panotools-Script/Panotools-Script-0.25.ebuild,v 1.1 2010/04/17 11:20:04 tove Exp $
+
+EAPI="2"
+
+MODULE_AUTHOR=BPOSTLE
+inherit perl-module
+
+DESCRIPTION="A perl module for reading, writing, and manipulating hugin script files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND="dev-perl/URI
+ dev-perl/libwww-perl
+ >=dev-perl/ImageSize-2.9
+ >=media-libs/exiftool-6
+ gui? ( gnome-extra/zenity )"
+DEPEND=""
+
+SRC_TEST="do"
+
+src_install() {
+ perl-module_src_install
+ if use gui ; then
+ insinto /usr/share/applications
+ doins "${S}"/desktop/*.desktop || die
+ else
+ rm "${D}"/usr/bin/*-gui || die
+ fi
+}
+
+pkg_postinst() {
+ einfo "Some of the scripts require 'nona', 'freepv', 'enblend', 'autotrace', and"
+ einfo "ImageMagick command-line tools which are available in the following"
+ einfo "packages: media-gfx/hugin, media-gfx/freepv, media-gfx/enblend,"
+ einfo "media-gfx/autotrace, and media-gfx/imagemagick."
+}