summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-02-06 15:09:38 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-02-06 15:09:38 +0000
commitc7ce45d2cc4d8f6d5c2c17b97dac908656e4ca63 (patch)
tree20e0abc82a7426300ea0716ee8f8764f2234c125 /dev-perl/Net-SSLeay/Net-SSLeay-1.30.ebuild
parentSince Aron retired, I'll take over (diff)
downloadgentoo-2-c7ce45d2cc4d8f6d5c2c17b97dac908656e4ca63.tar.gz
gentoo-2-c7ce45d2cc4d8f6d5c2c17b97dac908656e4ca63.tar.bz2
gentoo-2-c7ce45d2cc4d8f6d5c2c17b97dac908656e4ca63.zip
Version bump
(Portage version: 2.1.2-r5)
Diffstat (limited to 'dev-perl/Net-SSLeay/Net-SSLeay-1.30.ebuild')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.30.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.30.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.30.ebuild
new file mode 100644
index 000000000000..a57c23ef2b37
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.30.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-SSLeay/Net-SSLeay-1.30.ebuild,v 1.1 2007/02/06 15:09:38 mcummings Exp $
+
+inherit perl-module multilib
+
+MY_P=${PN/-/_}.pm-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Net::SSLeay module for perl"
+HOMEPAGE="http://search.cpan.org/~flora/"
+SRC_URI="mirror://cpan/authors/id/F/FL/FLORA/${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ dev-lang/perl"
+
+export OPTIMIZE="$CFLAGS"
+
+myconf="${myconf} /usr"
+
+src_unpack() {
+ unpack ${A}
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e "s:openssl_path/lib:openssl_path/$(get_libdir):" \
+ ${S}/Makefile.PL || die
+ fi
+}
+