summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-09-09 21:53:26 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-09-09 21:53:26 +0000
commit0227fa76a3c8d98584a051b7ab9d11704c8f0448 (patch)
tree29e1ea66f948bb8475e173b0b7af78a656c1b595 /dev-perl/Net-SSLeay/Net-SSLeay-1.19.ebuild
parentThis test eclass has been tested on all platforms and is no longer (diff)
downloadgentoo-2-0227fa76a3c8d98584a051b7ab9d11704c8f0448.tar.gz
gentoo-2-0227fa76a3c8d98584a051b7ab9d11704c8f0448.tar.bz2
gentoo-2-0227fa76a3c8d98584a051b7ab9d11704c8f0448.zip
These are syntax fixes for the new perl eclass. The new perl eclass uses a corrected makemaker for perl.
Diffstat (limited to 'dev-perl/Net-SSLeay/Net-SSLeay-1.19.ebuild')
-rw-r--r--dev-perl/Net-SSLeay/Net-SSLeay-1.19.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-perl/Net-SSLeay/Net-SSLeay-1.19.ebuild b/dev-perl/Net-SSLeay/Net-SSLeay-1.19.ebuild
new file mode 100644
index 000000000000..0e29a7bd3d66
--- /dev/null
+++ b/dev-perl/Net-SSLeay/Net-SSLeay-1.19.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-SSLeay/Net-SSLeay-1.19.ebuild,v 1.1 2002/09/09 21:53:26 mcummings Exp $
+
+inherit perl-module
+
+MY_P=${PN/-/_}.pm-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Net::SSLeay module for perl"
+SRC_URI="http://www.cpan.org/authors/id/SAMPO/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cpan.org/authors/id/SAMPO/${MY_P}.readme"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="${DEPEND} dev-libs/openssl"
+
+export OPTIMIZE="$CFLAGS"
+
+myconf="${myconf} /usr"